This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Lauren 6 months ago.

Assigned support staff: Lauren.

Author Posts
April 25, 2019 at 6:10 pm

esprits

I am trying to:Make my language switcher appear on translated page menus

Link to a page where the issue can be seen:hidden link

I expected to see:The link in the menu

Instead, I got:Nothing

April 25, 2019 at 6:48 pm
April 25, 2019 at 7:18 pm #3685487

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, do you still see the language switcher on the homepage?

The topic ‘[Closed] Language switcher not showing in translated page menus’ is closed to new replies.