This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Vincenzo 5 months, 2 weeks ago.

Assigned support staff: Vincenzo.

Author Posts
May 4, 2019 at 12:35 am #3738401

danielS-180

I am trying to: go from English to Spanish.

Link to a page where the issue can be seen: cochamo.com

I expected to see: Spanish from cochamo.com/es/

Instead, I got: re directed to cochamo.com again (English).

May 4, 2019 at 10:32 am #3739903

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

At the moment, I can't see the issue because the site is under maintenance.

1. Can you please go to Settings -> Reading and verify if the homepage is correctly set and there is no warning there?

2. Try saving the Permalinks again from Settings -> Permalinks

3. If the issue persists, I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

If you don't see the form below, please don't add your credentials as they will be publicly exposed:
hidden link

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

Thank you

May 4, 2019 at 4:16 pm #3740771

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

I just checked the site and I can see the cause of the redirect.

The current English homepage is "News". This page is not translated in Spanish.

You can verify this by going to Settings -> Reading and reading the warning message.

As soon as the News page will be translated, the issue should be fixed.

Please let me know if this solves the issue or if you need further details.

Thank you