This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to: Use language switcher between two languages, Spanish (default) and Catalan-Valencian.

Solution: - Update all outdated plugins. - Flush all cache memory. - I have set the Inicio page as front page in the Theme options and Settings -> Reading. Then changed the permalink structure in Settings -> Permalink and re-saved the permalinks.

Relevant Documentation:

This topic contains 6 replies, has 2 voices.

Last updated by Carlos Rojas 11 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 26, 2018 at 4:57 pm #2768233

ana-mariaQ

I am trying to: Use language switcher between two languages, Spanish (default) and Catalan-Valencian.

Link to a page where the issue can be seen: hidden link
There are two language switchers, one on top-bar-menu, left. Another on footer, right. None of them are working properly.

I expected to see: A switch to catalan pages, like hidden link

Instead, I got: No language switching, still charges againg the Spanish page.

After I installed the WPML, I bought an SSL certificate and activate it for the website. Thought it could be that problem, as described here https://wpml.org/forums/topic/cant-change-http-to-https-in-switcher/ but I followed steps, unistalling WPML, installing again, activating Really Simple SSL, clearing browse cache but didn't work.

Any advice, please?

September 27, 2018 at 9:30 pm #2771838

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

October 3, 2018 at 5:59 pm #2785440

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

Before we continue I need to ask you to update all outdated plugins and themes. Outdated functionalities can cause conflicts in the code.

Once the plugins and themes are up-to-date, please flush any cache memory that might exists and re-save the permalink structure.

Note: Please don't forget to create a full backup of the site before making any change.

Could you tell me if the issue persists?
Best regards,
Carlos

October 11, 2018 at 9:55 am #2807449

ana-mariaQ

Hi Carlos!

Updated plugins. Re-saved permalinks. Don't know if "flush any cache memory that might exists" is regarding to browser or to something else.

I flushed browser cache as always for last 7 days. The issue still persists

Sorry I haven't replied earlier, I can check from time to time. Thanks for your help.

Best regards,

October 11, 2018 at 7:37 pm #2809626

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I have set the Inicio page as front page in the Theme options and Settings -> Reading. Then changed the permalink structure in Settings -> Permalink and re-saved the permalinks.

The issue seems to be solved now. Could you double check it?
Regards,
Carlos

October 26, 2018 at 11:36 am #2852874

ana-mariaQ

My issue is resolved now. Thank you!

October 27, 2018 at 12:31 am #2854293

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos