Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Bobby 2 weeks, 6 days ago.

Assigned support staff: Bobby.

Author Posts
November 13, 2019 at 10:24 pm #4943247

martinK-104

My site is currently available in three languages: English, Spanish and Portuguese.
My language switcher suddenly stopped working on my homepage. It works everywhere but not on this page.
This page is correctly translated, so that seems no te be my issue.

Let me also comment you that my woocommerce shop page, is also my homepage. If i go to hidden link it works well... but if I go to hidden link (which is the same page) it doesnt work.

How can I solve this issue?

Thanks!

Thanks!

November 14, 2019 at 10:09 pm #4950523

martinK-104

Please, I have been waiting for more than 24 hs.

November 14, 2019 at 10:59 pm #4950683

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Please go to your database table wp_options and share with me a screenshot of your Home and SiteURL fields.

Are they correctly filled in?

When i review your source I can see that indeed under the homepage URL the hreflang is not correctly listed for both languages even though the page exists.

November 15, 2019 at 8:28 am #4951803

martinK-104

They are correctly filled. Can't find out what's the issue.

November 15, 2019 at 6:35 pm #4956201

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

It is possible that this might be caused due to your WooCommerce being the homepage, which would need further testing.

As a test please temporary change your homepage to a static page such as "About", or any other static page that is not the WC shop and let me know your results.
(Settings->Reading->Static Homepage->Select one)

Additionally, share with me a screenshot of your permalinks for the Shop within Settings->Permalinks

November 15, 2019 at 8:40 pm #4956669

martinK-104

I just changed the homepage to a static page and works correctly.

Let me comment you it was working well before. I think after updating woocommerce or WPML it broke.

November 15, 2019 at 9:53 pm #4956973

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed I recommend taking FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose: http://wordpress.org/plugins/duplicator/

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,
Bobby

November 18, 2019 at 9:49 pm #4967949

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

I was able to pindown what is causing this issue.

Your Homepage is set to the WooCommerce shop, but you currently do not have any products listed which results into that page not providing an active URL, which in turn is the reason your language switcher does not show an option for the rest of the languages.

(I used the WordPress function get_permalink() to get these results)

To resolve this go to your products-> and publish at least one of them.

Let me know your results.

November 19, 2019 at 6:28 am #4968731

martinK-104

I just tried and it seems to be working fine.

Thanks a lot Bobby! <3

November 19, 2019 at 7:02 pm #4975387

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Glad to hear that the issue has been resolved! 🙂