This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Language switcher not working on WooCommerce Shop page

Solution: Deactivating/activating WooCommerce Multilingual helped to solve the issue.

0% of people find this useful.

This topic contains 6 replies, has 2 voices.

Last updated by fredericE 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 10, 2019 at 9:41 am #3782837

fredericE

Hi,

Our woocommerce shop is translated in Danish, English and French. Danish is set as the site's default Language.

Our Theme is Avada 5.9.1 with child Version: 1.0.0

We have translated all the shop pages as follow:
hidden link (danish)
hidden link (english)
hidden link (german)

The language switcher works fine on every page, except on the main shop-page:
When we go to the Danish shop page and click on the language flags, we always get redirects to the danish page hidden link . The same happens if we type the direct URL for the language directly.

We also set a Shop page in WooCommerce -> Settings -> Product. (see screenshot)

Could it be an issue with permalinks?

Thank you in advance
Fred

May 10, 2019 at 11:31 am #3783749

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Could you please check if the English and German pages are set to publish, sometimes when translated pages are set as a draft this type of issue can appear.

Further, could you please go to WPML-> Support ->Troubleshooting and click the below buttons:

+ Clear Cache in WPML
+ Set Language information
+ Fix element types collation
+ Remove ghost entries from the translation tables
+ Assign translation status to duplicated content
+ Set language information

Let me know how it goes.

Thanks

May 10, 2019 at 12:55 pm #3784399

fredericE

Hi,

I can confirm that the page is all in 'published' status.
I have click all the buttons you asked me in WPML-> Support ->Troubleshooting but my issue is still not resolved.

Can you please assist further.

Regards,

May 10, 2019 at 4:27 pm #3786679

fredericE

Fix by deactivating woocommerce and reactivate again My issue is resolved now. Thank you!

May 10, 2019 at 4:43 pm #3786777

fredericE

Hi,

It looks like the fix was only temporary.
We still need help to understand what is going on please

May 13, 2019 at 3:20 am #3794623

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Fix by deactivating woocommerce and reactivate again

Is the issue appearing again? Could you please monitor the changes and let me know if the issue exists again, so I can debug it again?

Look forward to your reply.

Thanks

May 16, 2019 at 8:33 am #3823265

fredericE

My issue is resolved now. Thank you!