This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Language switcher is disappeared

Solution: It was either caching or CDN issue. Disabling CDN and then re-enabling it fixed the issue.

This topic contains 2 replies, has 2 voices.

Last updated by viljoM 2 weeks, 2 days ago.

Assigned support staff: Riffaz.

Author Posts
October 2, 2019 at 11:08 am #4679541

viljoM

I am trying to: get language switcher to menu bar. Settings should be fine, but it just doesn't appear. The menu was fine, but for some reason the wpml was disabled and after enabling the plugins, the menu was without language switcher.

Link to a page where the issue can be seen: harmonikanrestaurointi.net

October 2, 2019 at 11:28 am #4679775

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

If you disable your CDN and cloudflare do you see the same issue?

If you add language switcher to the footer do you see it?

Let me know.

Regards,
Riffaz.

October 2, 2019 at 12:07 pm #4680053

viljoM

It seem that there was several things failure at the same time. I did take CDN off and it didn't work. After enabling it again, it worked. However, I had cache files which might have effected to the matter. So I cannot tell directly what was wrong, but now it seems to work. Thank you for your fast reply!