This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 1 month, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
September 9, 2019 at 1:18 pm #4537481

king-yiuL

Tell us what you are trying to do?
- We installed WPML and configured from our website. Enable Custom language switchers and called from the header. But they're not showing.

Is there any documentation that you are following?
- Yes, we followed the same as per your instruction in the website document.

Is there a similar example that we can see?
- yes i have attached the screenshot

What is the link to your site?
- hidden link

September 9, 2019 at 10:17 pm #4540403

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Do I understand right, that the WPML Menu Language Switcher was not working on your theme and you are now trying to add the Custom Language Switcher?

Did you place this code inside of the header.php?

do_action( 'wpml_add_language_selector' )

It should be placed right inside the navigation div wrapper

<div id="site-navigation-wrap">
// nav elements
 
// Langage swticher here
do_action( 'wpml_add_language_selector' );
</div>

If so, please check your theme options, as it seems ot be that the theme is using its own switcher. Try to disable it.

If this will still not solve the issue, please try if the issue ersists when using a default theme like TwentySeventeen after applying the above mentioned code repsectively.

Kind regards
Andreas

The topic ‘[Closed] Language switcher options Not showing in the Webpage’ is closed to new replies.