Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Leif-Erik 4 years, 9 months ago.

Assigned support staff: Maciej.

Author Posts
February 15, 2015 at 1:32 pm #560943

Leif-Erik

I am trying to: Get my language switcher to point to correct translated URL's

I visited this URL: hidden link

What's wrong: From main index page, if I want to switch language to Swedish. It brings up most recent post done (in archive) and not the translated "index" page. It seems to be pointing to wrong URL modehusetchic.se/?cat=10&lang=sv (same for the german URL).

It seems only to effect theFirst Index page Language Switcher options

February 16, 2015 at 10:21 am #561250

Maciej

Thank you for reporting this issue.

Does this happen when you disable all none related to WPML and WooCommerce plugins?

February 16, 2015 at 11:40 am #561316

Leif-Erik

I have tried to deactivate any none related plugins, but problem is still there.

So what I did weretocreatea NEW post "TEST" inall languages and then the switcher worked. I then deleted the "TEST" post and it works fine now....