This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 3 voices.

Last updated by domenC 11 months, 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 6, 2019 at 7:23 am #3966465


We are using WPML Multilingual CMS 4.2.6 on WordPress 5.2.1

Two languages are set:

Main: EN English
Secondary: RU Russian

Language URL format: A different domain per language

EN ->
RU ->

The problem is:

When switched to the secondary language (RU, and the current domain is, the EN icon points to instead

So, basically when switched to Russian we have two flag icons (EN, RU) in the language switcher and they both point to, and there's no way to get back to English.

June 6, 2019 at 1:41 pm #3969585

Carlos Rojas

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thank you for contacting WPML support.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,

June 6, 2019 at 4:07 pm #3970721


Hello, Carlos,

Thank you for your reply.

I've performed all the steps you suggested except for switching to a factory theme (we have only Divi theme at the moment)

The problem is still there.

As far as I can see this problem has been occurring to other WPML users for a few years already:
Although, all suggested solutions are obsolete to the current version of WPML.

Can you pass this issue to the 2nd tier support? I need help with debugging this issue on backend.

June 6, 2019 at 11:11 pm #3972413

Carlos Rojas

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,
Thank you very much for your message.

Before escalating this ticket to our 2nd tier of support I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.


April 16, 2020 at 6:50 pm #5926751


Hi, I'm having the same problem with my website hidden link

It switches to Croatian(hidden link) domain correctly, but once on that domain the Slovenian link does not point to hidden link but to hidden link

I see that this topic is marked as resolved. Can you let me know what the issue was and how it was resolved?

Also how can I set Croatian domain to hidden link currently if I do so the domain check returns an invalid status.

Kind regards,

April 17, 2020 at 8:48 am #5930263


Small update: I have added a temporary static lang switcher(that points to home url for each domain). I have set that if you are an admin you can see the wpml langswitcher. Let me know where I can send you a temp. admin user so you can see the settings and let me know what the problem is.

Kind regards,