Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by francoisB 5 years, 1 month ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
June 28, 2015 at 4:46 am #647786

francoisB

I am trying to: From this link below, when I want to switch to the English page, the url is simply wrong and you can already see it when hovering over the English flag (hidden link)

URL of (my) website where problem appears: hidden link

I expected to see: hidden link

Instead, I got: hidden link - which is of course an error page

June 29, 2015 at 1:13 pm #648427

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thank you for contacting our support forum.

This could be a compatibility issue , your theme is not among our compatibility list : https://wpml.org/documentation/theme-compatibility/ .

So Could you please try one of the default WordPress theme , and see if the problem still exists .
If it still exists , activate only the WPML WooCommerce Plugins , and test again.

Also please go to WPML -> String Translations , navigate to "Original language of strings", and make sure that you are selecting English.

Then go to your Permalink Settings and re-save them.

Please let me know if that helps you .

July 1, 2015 at 9:08 am #650173

francoisB

Hi Ahmed,

I did everything you said. Still same problem: hidden link

I use a backup of the original site to do the tests.

July 1, 2015 at 11:09 am #650345

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks for your reply.

I need to request temporary access (wp-admin and FTP) to your site in order to provide a better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

+ Please make sure that you have a full backup of your website and database. (Please don't ignore this)!
+ It'd be great if you give me an access for a test site where the problem is replicated.

Best Regards.

July 2, 2015 at 9:17 am #651088

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks for your data .

Could you please recheck your credentials , It gives me wrong access message and finally it blocks me from seeing the page .
I will set next reply as private , to put the right credentials .

Best Regards .

July 3, 2015 at 8:55 am #651947

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi ,

I think It is working fine now , please check it know : hidden link .

Please go to your Permalink Settings , and insert the "product-category" at the "Product category base" field , and do the same for "Product-tag".

Then go to WPML -> String translation , and translate them.

Please let me know if that helps you

July 3, 2015 at 9:13 am #651968

francoisB

Well done sir!

Thank you very much for your help, all good.

Enjoy the weekend!