Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I can only see ??????? instead of my text on some strings.

Solution: That usually happens when you use the wrong alphabet on languages that do not accept them (like chinese characters on a russian locale, etc). Please go to WPML > Languages and make sure you have the right locale and code for your language.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 3 voices.

Last updated by AaronG1 1 year, 3 months ago.

Assigned support staff: Alejandro.

Author Posts
April 9, 2019 at 1:46 pm #3567493

AaronG1

hidden link

in this page it is not showing language name properly.
It is showing ???????.

April 9, 2019 at 2:21 pm #3567911

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

1. Usually, this issue is not caused by WPML.
You can verify this by disabling WPML and setting the WordPress language to Arabic or Chinese from Settings -> General.

The most likely cause is the database character encoding that is different than UTF-8.
See this article for more details:
- https://wpml.org/faq/texts-showing-as/

2. I can see that you are not using the latest versions of WPML and of its add-ons.
You can check the latest released versions under “My Account -> Downloads” on this site.
- https://wpml.org/account/downloads/
Instructions to update can be found here:
- https://wpml.org/faq/install-wpml/#automated-updates

❌ Before proceeding please make a full website backup! ❌

Please let me know if this solves the issue or if you need further details.

Thank you

April 10, 2019 at 7:21 am #3573033

AaronG1

The database structure is same as well as this site hidden link
database is same to same then why this site is causing issue.
hidden link

April 10, 2019 at 7:23 am #3573063

AaronG1

The database structure is same as well as this site hidden link
database is same to same then why this site is causing issue.
hidden link

Note :- actully this issue is generated after site transfer on another server from wpengine to site ground.

April 10, 2019 at 8:32 am #3573521

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

1. Can you please tell me which method did you use for the site's transfer?
I use Duplicator daily and it works fine every time.
- https://toolset.com/faq/how-do-i-migrate-a-wordpress-site-from-one-domain-to-the-other/

2. Can you please tell me the results of the test steps outlined in point 1 of my previous reply?

3. If you wish, I can test your working site on my local server. Please let me know and I will enable a private answer to share it with me.

Thank you

April 10, 2019 at 8:52 am #3573711

AaronG1

I have used this method to transfer the site
hidden link

i have used same method for both of are site but site is running well here
hidden link

also both site are on same server

April 10, 2019 at 9:05 am #3573953

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

to further debug the problem I’d like to replicate your site locally.

I would need a site snapshot of the original one (the one without the issue), if possible.
We usually recommend the free Plugin “Duplicator” for this purpose.

If you already know how Duplicator works
(https://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the archive file you downloaded.

★ Duplicator Instructions
hidden link
https://wpml.org/faq/provide-supporters-copy-site/

If the file is too large (more than 500M), please use the Duplicator file filters to remove the cache, the wp-uploads directory, the media, and the archive files.

Send me the link to the archive file (you probably want to use Google Drive, Dropbox, or similar services, as the snapshot file will be quite big)

Your next reply will be private, which means that only you and I will be able to see it and have access to it. You can paste the link to the file there. You can also share the credentials to your website. I will then download the file from the admin panel.
Once the problem is resolved I will delete the local site.

Please let me know if you need help creating the Duplicator package.

Thank you

April 11, 2019 at 12:26 pm #3587347

AaronG1

Not get any update after my reply...?

April 11, 2019 at 4:17 pm #3590433

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

sorry for the delay.

I had some issue downloading the Duplicator copy of the site from Drive.

I installed the site on my local server and the site works perfectly, as you can see in the attached screenshot.

Can you please try using Duplicator to migrate the site on the affected site?

Try also purging all the cache using the controls provided by the two cache plugins.

Thank you

April 20, 2019 at 9:45 am #3649971

AaronG1

Hello
I had reverted my website backup. after that the issue had been gone. After one day I am trying to ad a Persian translation of:
hidden link
When I tried the flag problem returned:

please help this is wpml plugin's issue.

April 22, 2019 at 4:37 am #3653901

AaronG1

Not getting your reply?

April 23, 2019 at 6:22 am #3659759

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,
Vincenzo is on vacations so I'll take care of this. Ticket if it's not a problem for you.

Would you mind giving me access to the site, where this is happening please so I can check what is going on?

I enabled the proper fields for that so please add the credentials there.

Thanks

April 24, 2019 at 4:22 pm #3675125

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, we can tackle the image issue after we finish with this, or you can open another ticket about it, in the meantime because we can only check one issue per ticket (this way we avoid confusion and future readers who relate with your situation can find a solution faster).

I just checked and the problem seems to be that somehow all the language's Letters changed to "???", they are not encoded, they are not "transformed" like that they seem to have been added manually like that, which is very weird.

You just need to go to WPML > Languages > Edit Languages > and change the name in the correct alphabet and save it and that's it.

Please change the letters and confirm this problem is fixed so we can move to the next topic (the image issue).

Regards.

April 25, 2019 at 5:04 am #3678839

AaronG1

This solution is not working.
I have added manually arabic language name "عربى" in edit language settings. After adding it also convert "عربى" to "????".

I have given you admin access you have permission to do anything for fix the issue. Please fix this issue asap.

April 25, 2019 at 9:18 am #3680415

AaronG1

Now i have updated all wpml plugins. After update i am able to change language name in edit languages settings. But still issue is there i am not able to change "urdu" language.
The urdu language is still showing ?????.

Please fix it asap.