This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
We want to hide the submenu coming from adforest theme.

Solution:- Go to WPML > Languages > Language switcher options > - Additional CSS (optional).
- Add the following CSS:

.mega-menu .menu-links > .hoverTrigger:last-child ul {
    display: none;
}

Relevant Documentation:
https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

This topic contains 12 replies, has 2 voices.

Last updated by riseC 4 months, 2 weeks ago.

Assigned support staff: Andrés.

Author Posts
May 28, 2019 at 11:44 am #3906375

riseC

Hello,
We are using megamenu at our primary menu and appear sub-menu when hover over it

May 28, 2019 at 2:25 pm #3907853

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Thank you for opening a new ticket! 🙂

I have created a test website with a clean WordPress install. You can access it through this link:
hidden link

Please upload your plugin Mega Menu to this test install and setup it the same way as in your website. In this way we can check if this is a compatibility issue.


Please note that we only need the plugin and the related functionality, you don't need to setup a entire website or clone your existing site.

Best regards,
Andrés

May 29, 2019 at 8:11 am #3912863

riseC

Hello Andrés,
Our theme does not have a mega menu plugin it has a built-in mega menu.
We uploaded theme so you can check it

May 29, 2019 at 1:02 pm #3915729

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Oh, I thought it was an extra plugin. In that case, could you help me replicating the issue? How can the menu be added?

Regards

May 29, 2019 at 1:27 pm #3915949

riseC

Hello Andrés,
Thank you for your cooperation,
We add pages to theme primary menu and in every menu item there options we choose mega menu
Thank you.

May 29, 2019 at 2:37 pm #3916449

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thanks for your comments, this is what I've done so far:
- Created a menu and translated in all languages.
- Added WPML as a menu language switcher.

However, it does not behave on the same way that the way on your site.

May 30, 2019 at 7:22 am #3920933

riseC

Hello Andrés,
We did what you said and still give us submenu
Is there a custom css code for this issue
Thanks.

May 30, 2019 at 8:35 am #3921367

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there, 🙂

Sorry for the misunderstanding, what I meant is that I couldn't reproduce it in our test site. Is there any step missing?

So far, I don't have an easy CSS for fixing this issue, that's why I'm trying to replicate it in our test site.

Thank you for your help.

May 30, 2019 at 9:33 am #3921735

riseC

Hello Andrés,
We Replicated menus at test site.
Thanks

May 30, 2019 at 9:58 am #3921857

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Thank your for your help, the issue is almost the same but not totally, so I want to be completely sure:
- Could you please tell me which was the missing step?
- The issue is that the menu is another position (screenshot and it is not in your test)
or
- Just the fact that the language name is repeated.

Regards

May 30, 2019 at 10:15 am #3922009

riseC

Hello Andrés,
You can check our website and when you hover over language switcher you will see replicated submenu
We set wpml switcher List of languages
If you want WordPress login please tell us it is good for you to understand our issue
thanks

May 30, 2019 at 10:37 am #3922185

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Perfect, let's try the following:
- Go to WPML > Languages > Language switcher options > Additional CSS (optional).
Add the following CSS:

.mega-menu .menu-links > .hoverTrigger:last-child ul {
    display: none;
}

Documentation:
https://wpml.org/documentation/getting-started-guide/language-setup/custom-language-switcher/

May 30, 2019 at 10:46 am #3922255

riseC

My issue is resolved now. Thank you!
Thank you, Andrés you are the best.