This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Ricardo Alday 1 year, 1 month ago.

Assigned support staff: Ricardo Alday.

Author Posts
September 12, 2018 at 10:56 pm

judithK-5

I am trying to:
switch the language with the switcher to an other language.
The language switch bit it alway end un the home.
Ich have two language German an englisch.
for example choose the switcher when im on following site from german to english:
hidden link
it should go to:
hidden link
but it ends:
hidden link

See my settings:

September 14, 2018 at 7:56 pm #2736610

Ricardo Alday

Hi,

Thank you for contacting WPML support. Were you able to fix the problem?
I visited your first link and when I click the English item on the language switcher it correctly redirected to the English translation of the page, not the homepage.

September 16, 2018 at 8:22 pm #2739156

judithK-5

Hi Ricardo,

thanks for your replay. But it doesn't work when I test it.
I will explain my problem again:

Im on the german site
hidden link
If I switch the language
I want to land on the same site in english:
hidden link
but instead it opens the home in english.

I have also a problem with sites with the same name:
e.g.: software.
hidden link

hidden link

When I set the link in the Button (see screen) it opens always the german site inters of the english

September 16, 2018 at 9:07 pm #2739189

judithK-5

Do have to set all the links new? Is there a better way to do that?
e.g. button below:
hidden link

September 17, 2018 at 10:21 pm #2742744

Ricardo Alday

Thanks for the explanation. I could not replicate the issue on the links you posted but it happens on the homepage on your site.
In your WordPress admin go to Qode Options -> General -> Settings -> Page Transition and select any other option that is not "Fade".

Let me know if that helps.

The topic ‘[Closed] Language switcher switches to homepage’ is closed to new replies.