This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 5 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
May 2, 2019 at 5:07 pm #3727497

joshM-2

I want it so when the language switcher to go to the exact URL, not the home page for example.
hidden link to hidden link and vice versa.

Rather than when a flag is clicked going to the homepage.

Thank you in advance

May 2, 2019 at 6:59 pm #3728503

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

In fact, the language switcher will always redirect to the same URL in different language only if the page, post or product has been completley translated. Could you please verify if this is the case?

If the content is already to 100% translated please try the following.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

The topic ‘[Closed] Language switcher to go to the exact URL’ is closed to new replies.