This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by julianZ-4 1 month, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 15, 2019 at 3:34 pm #4402251

julianZ-4

I am trying to: I have integrated the langauge switcher inside the footer on my website blackfridaydeals.ch. The widget gets displayed, but is not clickable (you can not switch the language)

Link to a page where the issue can be seen: hidden link hidden link => nothing happens on click. I don't see any JS errors.

In the backend, the dropdown works. See settings: hidden link

August 15, 2019 at 7:12 pm #4403155

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Can you please confirm if your homepage is fully translated and these translations are marked as 100% completed? The language switcher will only show the language options if there's an actual complete translation in the mentioned page. See: https://wpml.org/documentation/getting-started-guide/#how-to-translate-pages-posts-and-custom-posts

Please, let me know so we can proceed with a detailed investigation. Have a nice day.

August 16, 2019 at 6:51 am #4404931

julianZ-4

Hi Marcos

Thanks for your response.

I confirm that most pages are translated and it does not work for translated pages p.e. Homepage: blackfridaydeals.ch / blackfridaydeals.ch/fr/ blackfridaydeals.ch/it/

August 16, 2019 at 2:42 pm #4407095

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I've requested some WordPress Dashboard access in your other ticket I am dealing with (https://wpml.org/forums/topic/translation-for-1-author-description-does-not-work-all-other-authors-work/). As soon as you provide it I will proceed with a detailed investigation. Thank you for your collaboration and patience, have a nice day.

August 20, 2019 at 1:33 am #4419733

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Julian,

Thank you for the updates. As explained in you other ticket I am dealing with (see https://wpml.org/forums/topic/translation-for-1-author-description-does-not-work-all-other-authors-work/) part of your issues seems to be related with your theme. I tested your website using a minimal setup with all the plugins disabled and the footer widget language switcher remains with the same issue while it works properly when used in the main navigation (see hidden link). We need to run a compatibility test here using your theme, for that, please proceed this way:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

August 20, 2019 at 7:09 am #4420993

julianZ-4

Hi Marcos

I've installed the theme on the test-system. I can not reproduce the error, the switcher works as it should... You can see it here: hidden link

How to proceed?

Best regards

Julian

August 20, 2019 at 2:44 pm #4424535

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Julian,

Thank you for the updates. I saw you uploaded the parent theme while in website you seem to be usind a custom child version theme. Can you please, upload your child theme to test environment as well? Thank you for your collaboration, have a nice day.

August 21, 2019 at 7:38 am #4428611

julianZ-4

Hi Marcos

Thanks for your response.

I also installed the child-theme. Still, the language switcher is working.

I also tried it out on my other site preispirat.ch which uses mostly same plugins / theme / customizations => there, the language switcher does also not work.

August 21, 2019 at 6:23 pm #4434593

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Julian,

Please, take a look at my private reply above. Thanks!

August 22, 2019 at 7:43 am #4437153

julianZ-4

Hi Marcos

Thanks a lot. The migration is complete now.

Best

Julian

August 22, 2019 at 8:10 pm #4442719

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Julian,

Thank you for the updates. After a detailed and extensive investigation I noticed your theme for your current website is defining the overflow of the footer widgets as hidden and it makes the dropdown to be hidden, in order to fix it, please add the snippet of CSS code below in your WordPress Dashboard > Appearance > Customize > Additional CSS:

.footer-bottom .widget_icl_lang_sel_widget {
	overflow: visible!important;
}

The code that makes it hidden if coming from your parent theme, it is weird because it doesbn't affect the sandbox test website, maybe it is related with the choices you have in your theme options. In any case, the solution above is simple and effective. Please, let me know if you need any additional assistance and clarifications, have a nice day.

August 23, 2019 at 9:15 am #4445635

julianZ-4

Hi Marcos

Thank you very much! I would've never found that!

My issue is resolved now. Thank you!