This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The Language Switcher is not showing on the forums page when using the BBPress plugin.

Solution:

In this case, the post type 'forums' was set to 'Not translate'.

Go to WPML -> Settings -> Post Type Translation and set it to 'Translatable - use translation if available or fallback to default language' or 'Translatable - only show translated items' and save the setting.

Relevant Documentation:

https://wpml.org/documentation/getting-started-guide/translating-custom-posts/

This topic contains 19 replies, has 2 voices.

Last updated by antonA-6 1 year ago.

Assigned support staff: Itamar.

Author Posts
September 19, 2018 at 1:00 pm #2748829

antonA-6

I am trying to: make Language switcher appear on the forum pages like it does on the rest of the site.

Link to a page where the issue can be seen: hidden link and hidden link

I expected to see: Language switcher

Instead, I got: nothing.

I don't need translations and stuff. I switched to your plugin from qtranslate and before it was fine! I just need this tiny div with 2 flags present on the forum pages!

September 20, 2018 at 8:57 am #2751531

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see the issue on your site. It is not yet clear to me why on the forums section of your site WPML's Language Switcher is not showing. Currently, you are showing the Language Switcher on the header.
How have you placed the Language Switcher in the header?
Is it the same header that for the forums section and the rest of your site?
Could please also try to place a Language Switcher in the menu and sidebar and see if it shows in the forums section?

Thanks,
Itamar.

September 20, 2018 at 9:05 am #2751553

antonA-6

Hello. I added it in widgets section: hidden link
I tried to add language switcher in menu and in the footer. It doesn't appear in the menu on the forum pages, and the footer looks like this: hidden link

September 20, 2018 at 11:25 am #2751947

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra details.

I can see that you are using the BBPress plugin to create your forums.
Is it correct?

If it is correct, I've found that this issue (or very similar to it) is known to us and we have published an errata about it which you can see here.
https://wpml.org/errata/bbpress-language-switcher-not-working-on-user-pages/
Is it possible for you to check if the code snippet on this errata page is also fixing the issue on your site?
You will need to place it in the functions.php file of your theme.

Regards,
Itamar.

September 20, 2018 at 11:39 am #2751957

antonA-6

Well, I've stumbled upon this solution first thing, but it doesn't work for me.

September 20, 2018 at 12:41 pm #2752133

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

OK, thanks for letting me know about this.
This is probably some variation of the same issue.
I'll need now to see if I can replicate this on a clean WordPress installation with BBPress and then escalate to our compatibility team so they will try to find a fix also for this specific issue.

I'll keep you updated here.

Thanks,
Itamar.

September 20, 2018 at 8:07 pm #2753215

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've tried to replicate this issue on a clean WordPress installation but I couldn't. When I use BBpress on a clean WordPress installation with WPML, I do get the Language Switcher shown on the 'forums' page. Please see the attached screenshot.

I suspect that there is a collision with the theme or another plugin.
If possible get your site into a minimum environment.
Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated but WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twenty-sixteen (for example).
If it persists, then turn off all plugins except the WPML and its add-ons and BBpress itself but without any of its add-ons.
Then please check if the problem persists.
If it does not persists so start by activating the plugins one by one and check when the problem comes back. Then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

September 21, 2018 at 9:20 am #2754528

antonA-6

I've tried with a default theme, but to no avail. Disabling all my plugins is a bit too much for a tine div. I've payed for your plugin and all got is problems for now, that I fix mostly myself. What for did I payed then?

September 24, 2018 at 2:31 pm #2760785

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I'll be happy to continue helping you with this issue. If you cannot deactivate all the plugins, I'll do it for your with your site's copy on my local server. This way there will be no risk of making harm to t=your live site.

If you agree, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue.
You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

If you prefer to do it on your own, you can provide me with the snapshot of your website following these directions:
If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.
Duplicator instructions
- From the WordPress plugin page, look for “Duplicator” and install it.
- Once installed, you get a new item in the main menu “Duplicator.”
- Chose “Packages.”
- Click on the first button you find in the toolbar on the right (“Create Package”)
- Give it a name or leave it as is
- Click on “Create Package Set.”
- Wait until the package is ready
- Click on “Installer”, then on “Package”: the first one is just a PHP script, the second one is a zip file containing everything you need
- Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big).

***********************
Once the problem is resolved, I will delete the local site.
***********************
IMPORTANT: Be sure to take a complete backup of your site and database first before you proceed!
***********************
Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please, could you provide me the additional Info and as well permit me to perform the required steps?

Thanks,
Itamar.

September 26, 2018 at 4:18 pm #2768085

antonA-6

Hello, maybe you can somehow cooperate with this guy: https://wpml.org/forums/topic/woocommerce-endpoints-2/

September 26, 2018 at 8:17 pm #2768623

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Sure, we cooperate on a daily basis. But the issue in the other ticket is different from this one. Do you mean that I'll get the access details to your site from the other ticket?

September 26, 2018 at 9:36 pm #2768809

antonA-6

I can give you details.

September 27, 2018 at 11:12 am #2770258

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Please do give them to me.
I'm enabling private message for the next reply.

Regards,
Itamar.

September 27, 2018 at 6:29 pm #2771581

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've installed the Duplicator Pro, and indeed it is not working when I try to create a package.

I've noticed that you are using a cache plugin WP Super Cache.
Could you please try the following?
1. Clear the cache on the site.
2. See if the problem persists.
3. If it does persist then, please deactivate the cache plugin.
4. Take a backup of the DB of your site.
5. Go to WPML -> Support -> Troubleshooting (link)
6. Once on the troubleshooting screen press the following buttons and check if it helps.
Press each button at a time and wait for the process to complete.
- 'Disable cache for language switcher templates'
- 'Clear the cache in WPML'
- 'Remove ghost entries from the translation tables'
- 'Fix element_type collation'
- 'Assign translation status to duplicated content'
- 'Set language information'
- 'Fix terms count'
- 'Fix post type assignment for translations'

*** Please make a backup of your database before using this.***

7. Check if it fixed the issue.

Meanwhile, I'm also contacting Bigul my colleague from the other ticket to ask him to share with me the copy of your site if he still has it.
Do allow me to get the copy of your site from him?

Thanks,
Itamar.

September 27, 2018 at 6:54 pm #2771607

antonA-6

Hello. Done that and it doesn't worked. Of course, you can ask him for the copy.