Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.61 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Raja Mohammed 2 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
March 3, 2021 at 6:29 am

John Lemt

I have a relative uri on my website, pointing to language switcher:
//wordpress-158747-1742649.cloudwaysapps.com/wp-content/plugins/sitepress-multilingual-cms/templates/language-switchers/menu-item/style.css?ver=1

To increase the safety of my site I have been advised to change this into http:// link.
I have tried to follow instructions on below pages, but no success. I have installed SSL plugin and have also changed database by hand wp_option. Plugin does not change this setting (no change after installation) and database change is returned to old relative uri as soon I new user downloads the site. Any change in database looks like is overwritten.

March 3, 2021 at 7:44 am
March 4, 2021 at 7:09 am #8224349

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I dont seem to have any clue on this, Can you please also try clearing the server cache may be its related. Cloudways has varnish cache by default . Give it a try and let me know the results .

March 4, 2021 at 7:37 am #8224491

John Lemt

I have now disabled Varnish on Cloudways for hidden link
Yesterday I purged Varnish several times (around 10 times, 5 of which was during our chat-for every change)
I find it especially strange, if I go into database table wp_options there is option_id:17917 and
option_name:wpml_language_switcher_template_objects
which has option_value which includes this problematic link without https:
If I edit this manually, go out of database, go back, the change stays the same (everything OK).
But when I download main page hidden link this line in wp_options changes back to its original value without https

There is a code which generates this line every time webpage is called. You need to change only this code.

March 4, 2021 at 12:24 pm #8227327

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

May i request your permission to install database plugin to the cloudways site ? Let me check for a few things.

March 4, 2021 at 3:17 pm #8229403

John Lemt

No problem.
You can install anything. This is cloned site.

March 5, 2021 at 8:59 am #8234959

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I checked this further and it is expected that the template style loads wihtout any protocol that is prevent mixed content issue. This is a practice in use even in WordPress default theme refer to the screenshot.

I am not sure why it is marked as security issue if you have any details realated to it kindly share with us.

As far as i see this should not cause any issues to the site.

Screenshot 2021-03-05 at 12.58.25 PM.png