This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 year, 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
October 19, 2018 at 5:03 pm #2832752

albertoP-18

Hello,

I would like to activate the url of the language hidden link but it does not work why?

Thanks you

October 19, 2018 at 8:44 pm #2833036

albertoP-18

Problem see photo.

I would like to remove the .it/it but it does not work.

Thanks you

October 22, 2018 at 5:18 am #2836782

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Can you please elaborate a little more so I can better understand? Could you please provide more information about the errors?

Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Could you please perform the below steps and share me the results?

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Further, for helping further on this issue it's very important to know your site related information such as themes used, plugins used, PHP versions etc. You can easily send this using Debug information settings from WPML. So could you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Regarding the message showing on the second screenshot, could you please dismiss the message once and let me know if it appears again?

Look forward to your reply.

Thanks

October 22, 2018 at 3:31 pm #2838679

albertoP-18

Hello,

I forwarded the information.

- I would also like to translate the product URL.

Current URL: hidden link

Translation like this: hidden link

Thanks you

October 23, 2018 at 9:19 am #2841659

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

- Go to WooCommerce->WooCommerce Multilingual -> Store URLs and translate the slugs accordingly.
- Once saved go to Settings->Permalinks and click on "save changes"

https://wpml.org/documentation/related-projects/woocommerce-multilingual/#translating-urls

Let me know if this helps.

Thanks

October 23, 2018 at 4:46 pm #2843607

albertoP-18

Hello,

I tried to change the url in English but it is not changed.

Thanks you for support

October 24, 2018 at 4:08 am #2844841

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To further debug this issue, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

October 24, 2018 at 11:26 am #2845973

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see the issue, to further debug this issue I would need to replicate your site on my localhost and perform further debugging, I installed a plugin called duplicator for creating a package, but due to permissions I couldn't create a package, so could you please create a duplicator package and send it to me.

If the duplicator doesn't work, could you please provide me a backup of your wp-content (without uploads) as well as database backup so I can replicate your site on my localhost and perform further debugging.

You can zip these files and upload to google drive later to share it with me.

You can edit your previous private reply to send the updated details.

Thanks

October 24, 2018 at 2:08 pm #2846755

albertoP-18

Problem seems solved. We need to translate the product to make url work.

I encountered a problem with the Show more button in the categories. It does not seem to work.

see Attachment

October 25, 2018 at 9:19 am #2849222

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Glad to hear that it now works. As the original issue is resolved may I kindly ask you please to open a new ticket for your additional question? This will help us to discuss the issue on a ticket easily too.

This will help other users with similar problems to find solutions when searching the forum.

I tried to do a quick check but the login details don't seem to be working, so could you please provide the correct login details while opening a new ticket?

Thanks