This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Languages per directories does not work

Solution: Please go to go to Setting > Permalinks and just click save: https://take.ms/GYPJg

And, if you want to use that option you have to follow the steps, requirements and procedure of that: https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/ Please make sure you did all the steps explained there to work this option without any issue.

By following the above steps correctly the issue was resolved

Tagged: 

This topic contains 17 replies, has 2 voices.

Last updated by baSbuGK 4 weeks, 1 day ago.

Assigned support staff: Riffaz.

Author Posts
September 16, 2019 at 12:01 pm #4579943

baSbuGK

Hi, I just bought your plugin. I'm a little new. I made the attached change to the WPML settings. But now my English page won't open. I did something wrong. I'd appreciate it if you helped.

hidden link

En-version
hidden link

September 16, 2019 at 1:13 pm #4580607

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Please go to go to Setting > Permalinks and just click save: hidden link

And, if you want to use that option you have to follow the steps, requirements and procedure of that: https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/
Please make sure you did all the steps explained there to work this option without any issue.

Let me know how it goes.

Regards,
Riffaz.

September 16, 2019 at 2:18 pm #4581233

baSbuGK

Hi Riffaz
I don't want root-page. For example; I chose "English" on your homepage. I want an English version of my site. I do not want a root-page. Then what file do I have to choose?
I'm having trouble adjusting 🙁

September 16, 2019 at 3:08 pm #4581883

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Root page is mandatory here.

You can do this by creating a root page in WPML > Languages > Language URL settings. Next to the option to show a page for the root URL, click the link to Create root page.

If you want to force the primary language to display as hidden link (or anything you want) you will need to set up a redirect. To do that, please create a page template in your theme (or in a child theme) with the following content:

<?php
/*
Template Name: Root redirect
*/
wp_redirect( home_url() );
exit;
?>

use the correct url you want in the code above.

Then select this template for the root page in the WordPress page editor. Please see additional information here: https://wpml.org/forums/topic/error-in-plugin-php-after-update/

After creating this page template, your homepage will be accessed by yourdomain.com/en/

Please don’t hesitate to inform me in case the issue persists.

Regards,

September 16, 2019 at 7:24 pm #4583643

baSbuGK

Hello

I tried to, but I couldn't. Any video? I can do better by watching. My English is weak :(((

September 18, 2019 at 4:35 am #4592429

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Let me k now your site login details and your FTP/cPanel details.
I will see what I can do for you here.

The next reply is private.

Regards,

September 19, 2019 at 10:24 am #4603531

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for login details but I see just this if I try to login: hidden link
Credentials are incorrect.
Please check and update.
The next reply is private.

Regards,

September 22, 2019 at 2:14 pm #4618727

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Check the video: hidden link
Am I doing right or wrong?

Let me know.

Regards,

September 22, 2019 at 3:13 pm #4618835

baSbuGK

I decided I couldn't understand why the mistake. I created a 1-week temporary Administrator password with the plugin. I updated the latest private message and added 2 links. Can you check.

September 23, 2019 at 10:19 am #4622403

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Login token link works now. thanks.

I changed the language URL: hidden link and re-saved the permalinks but it does not work on the front end.
It should be caching issue.
I am afraid to disable the plugins as the language is not English.
Could you please disable all the plugins except WPML and check the issue?

Also, could you please change the profile language for the account 'RiffazWpml' ?
You can do that in User > RiffazWpml > Edit > language
I am unable to change this my self. I see this: hidden link

Do you understand Arabic?

Regards,

September 23, 2019 at 10:55 am #4622515

baSbuGK

Thank you very much. I have disabled all plugins. only WPML is active. The recipes page opens, but when I click on any recipe, it gives a "404-Page not found" error.

I changed the theme language to English.

I'm so sorry I don't know Arabic 🙁

September 24, 2019 at 6:28 am #4628281

baSbuGK

Hello, Riffaz,
I checked my settings from the beginning last night. It took a while, but I solved my problem. Thank you.

September 24, 2019 at 6:30 am #4628283

baSbuGK

My issue is resolved now. Thank you!

September 24, 2019 at 6:43 am #4628339

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for checking.

Now I am unable to login again: hidden link
Could you please disable all these security plugins till we sort this out, please?
So I can login anytime to check this.

Regards,

September 24, 2019 at 6:45 am #4628345

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

ok, great!
This is sorted out by checking the settings.
Sorry, I replied you before checking your last message.

Please close the ticket again. 🙂

Regards,