This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by dohunj 5 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 21, 2019 at 2:31 am

dohunj

I am trying to:
1. My landing page URL without a lang-line (xsperienza.it/it -> xsperienza.it)
2. know how to have the default language pages without a lang-line (My default is 'Italian' /it, so without it in the every pages in Italian.
3. fix one menu button 'Chi siamo/ About us' direct the old URL.
I've tried to go to settings > permalinks and click any option and back to the previous setting and save, etc. But it didn't work.

Link to a page where the issue can be seen:
(maintense mode now)
1.
xsperienza.it/it
3.
hidden link

I expected to see:
to get resolved

Instead, I got:

May 21, 2019 at 7:16 am #3852485

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have checked your site. To disable the language directory URL for default language,
Please go to WPML > Languages > Language URL format , disable the option "Use directory for default language". Once the option is disabled the root page will be disabled as well.

I hope this solves your issue.

Kind regards
Raja

May 21, 2019 at 9:43 am #3853637

dohunj

Dear Raja,

Thanks a lot!
You solved the most annoying issues I have. 😉

But, I still need you precious supports.

1. Landing page: Main bg image is not duplicated in english page from the Italian.
2. Products page: Going back to Italian page 'Prodotti'

I would be more than happy, if you could solve these issue as well.
Thanks a lot again.

Best Regards,
Yuluck

May 21, 2019 at 2:29 pm #3856161

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Yuluck,

I have set the translation priority of the custom field "page_header_bg_image" to copy, Please Update the home page and its translation the background image will be copied.

Regarding your second request, I can see the shop page is in trash kindly restore the shop page and translate it to English.

I hope this solves your issue.

kind regards
Raja

May 21, 2019 at 3:10 pm #3856479

dohunj

Thank you again for your kind support, Raja.

1.
I tried to update the home page.
I deleted the existing bg image and updated new one, but nothing happens on the english home page

2.
I tried to restore 'Products' page from trash, but I figured that that's old one, even though it directs that page and the menu becomes Italian.
As far as I understand, pages that has been translated in the 'Pages' section contain translated pages right? so you can't see the translated pages.

In that sense, I can see this restored 'Products' page.

Thank you in advance again for your support!

May 22, 2019 at 7:48 am #3862639

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Since you already have a translation of home in progress, please complete the translation 100% and deliver to the site.

Once done Update the original page and edit the translation, Please let me know if this helps.

- Sorry, I don't understand your second query, Are you trying to find the reason why the trashed page is displayed? This happens when you trash a shop page you should create a new shop page and link the page in the WooCommerce else the WooComerce will try to load the page from the trash. Please let me know if it is something unrelated to what you have requested here, Maybe a screenshot or a screencast explaining about the issue can help better.

Kind regards
Raja

May 22, 2019 at 9:37 am #3863787

dohunj

Hi Raja,

1. Homepage image issue.
I've updated translation. But, the issue is still there.
It doesn't appear..

2. Product page.
First of all, I think it's nothing to do with WooCommerce yet, because I didn't connect with it. You can consider it is just a normal webpage.
It seems for me, english link of product is somewhat with some reason connected to the trashed products page.
Well, it's kind of mess of it. Please suggest me which is the best way to do it.
In fact, I'm kind of thinking that permanently delete 'Products' and 'Prodotti' pages and create a new page for it. what do you think?

May 22, 2019 at 2:41 pm #3866805

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the clarification,

1) Please send me a snapshot copy of your site so that I can look into the issue without disturbing your live site You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

2) I think its best and easiest option is to recreate the store page, I hope that would solve the issue.

Kind regards
Raja

May 22, 2019 at 9:40 pm #3869475

dohunj

Hi Raja,

1) I find it slightly demanding to make a package, so please disturb my live site.
It's in a maintenance mode. I won't feel bothered your support.
Please find the attached 2 homepage (IT/EN) screenshots.

2) Yes, I will try!

Thanks!

May 23, 2019 at 10:36 am #3873787

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I think the issue is solved, I have set the all the page builder custom fields to copy to translation, Now the background image is visible in the english home page after the update. Please verify the same

Kind regards
Raja

May 23, 2019 at 11:49 am #3874815

dohunj

Hey Thanks again!

The images are there now!

1)
But, now the issue is opposite from the homepage.
As we talked, I created 'Products' again.
The link is fine, but the contents part is not duplicated this time(only a bg image)
Of course, you can make changes directly in my website.

2)
I would like to ask you delete my website name or hidden from the queue of this query.
Because it appears on the top of the google search page..

Thanks again!

May 23, 2019 at 2:28 pm #3876727

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The theme is missing the post type shortcode translation, I have added the custom XML in WPML > Settings > Custom XML Configuration, The English product page works fine now.

Site url is hidden from the public view it won't appear on the general search

I hope this helps you better

Kind regards
Raja

May 23, 2019 at 2:39 pm #3876981

dohunj

Thanks!

Yes, The products page is now done. Thanks to you.

But, This query still appears on the general search, though my cache has been deleted.
Then does it take time to be gone in Google?

Thanks!

May 23, 2019 at 2:43 pm #3877033

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The forum will appear on the Google search but your site URL will be hidden, only you and our supporters can see the site URL in the forum others don't have access to it.

Kind regards
Raja

May 23, 2019 at 3:04 pm #3877273

dohunj

My issue is resolved now. Thank you very much Raja!!!