Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.92 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:Language URL problem: It looks like languages per directories will not function.

Solution:"GoDaddy manages WordPress Hosting, where user is unable to change the homeURL of their site"

You will need to make sure in wp_options "home" field and site_url (blog_url) is not empty and this will fix the issue

1. Please contact your host provider (GoDaddy) they will work with you on fixing the issue

you need to make sure in wp_options "home" field is not empty and also site_url and this will fix the issue

In wp_options there is the site_url field and the home field both should contain your sites URL.

2. If you would like to give this a try you will need to access your database (using phpmyadmin mostlikely from your cpanel) and make sure in wp_options home field and site_url fields are not empty

Relevant Documentation:

This topic contains 11 replies, has 2 voices.

Last updated by cubi123 2 years, 11 months ago.

Assigned support staff: Bobby.

Author Posts
January 26, 2017 at 7:33 pm #1191833

cubi123

Hi,
our site: xxx.com
We are trying to use the format okxxx.com/en/page for the translations, the following error message appears when choosing 'Different languages as directories':

It looks like languages per directories will not function. Details

This can be a result of either:

WordPress is installed in a directory (not root) and you're using default links.
URL rewriting is not enabled in your web server.
The web server cannot write to the .htaccess file
How to fix
When WPML accesses /en?____icl_validate_directory=1 it gets:
A valid URL was not provided.

The expected value is:
<!--hidden link;

When creating a translated page it creates the following permalink: http:/en/en/xxx.com/en/

I have read relevant threads but can't seem to fix the problem. The web is hosted by Godaddy and it seems to be all ok on their part.

Thanks in advance!

January 26, 2017 at 10:58 pm #1191911

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting WPML Support,

Please do select languages per directories and ignore the message for now.

Go to the site's front end and let me know if its working as expected or if you are receiving an error.

Thank you !

January 27, 2017 at 10:34 am #1192199

cubi123

Hi Bobby!

Thanks for the quick reply, the translations on the frontend doesn't work 🙁

For e.g.
Page in Spanish: xxx.com

Translation in english shows the following url: hidden link
And 'page not found' is displayed (I attach screenshot)

January 27, 2017 at 8:43 pm #1192738

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

What is your permalinks structure under WP->Settings->Permalinks

Is wordpress installed in a directory ? Please verify this.

If permalink is set to anything but default and wordpress is not installed in a directory then please verify that you have contacted your host provider.

A lot of these issues have been resolved by the host providers in the past.

January 27, 2017 at 9:16 pm #1192753

cubi123

Hi!

Permalinks are set to 'Post name' and GoDaddy have told me it's all ok on their part (they tell me that wordpress is installed in root too, as they installed it automatically instead of me uploading it through ftp) and that it must be a problem with the plugin itself :/

Thanks!

January 27, 2017 at 10:43 pm #1192786

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Have you reviewed the documentation ?

https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

This error is caused because WPML is trying to get information that is not being provided to it.

If you’re using Apache and cannot activate language directories, check that mod-rewrite is active for your site. If you’re not sure how, shoot an email to your hosting providing.

Have they at least verified to you that mod-rewrite is on and active ?

Also can they verify that WordPress must be able to write to the folder in which it’s installed.

They said that everything is ok on their part but if possible you would need to make sure at least these two things are up and running.

January 30, 2017 at 1:06 pm #1193671

cubi123

Hi!

Yes, Godaddy tells me the mod rewrite is enabled and wordpress can write to the folder where it is installed

Thanks!

January 30, 2017 at 11:02 pm #1194338

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

January 31, 2017 at 10:19 am #1194634

cubi123

Hi Bobby!

Thanks for the recommendation on the plugin for the backup 🙂

I will be happy to give you access so you can help us out here, but I don't see the needed fields below the comment reply section.

Thanks!

January 31, 2017 at 7:50 pm #1195343

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Apologies for that , i have enabled the fields now

Thank you !

February 1, 2017 at 8:35 pm #1196719

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

I have duplicated and test your site on my local environment where everything is working as expected without any issues.

"GoDaddy manages WordPress Hosting, where user is unable to change the homeURL of their site"

You will need to make sure in wp_options "home" field and site_url (blog_url) is not empty and this will fix the issue

1. Please contact your host provider (GoDaddy) they will work with you on fixing the issue

you need to make sure in wp_options "home" field is not empty and also site_url and this will fix the issue

In wp_options there is the site_url field and the home field both should contain your sites URL.

2. If you would like to give this a try you will need to access your database (using phpmyadmin mostlikely from your cpanel) and make sure in wp_options home field and site_url fields are not empty

February 1, 2017 at 10:29 pm #1196795

cubi123

Hi!

I've given up on GoDaddy ... did it myself through phpmyadmin and all works fine now!
Thanks so much for helping even though in the end the problem had nothing to do with wpml!