Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Albert 2 years, 1 month ago.

Assigned support staff: Yvette.

Author Posts
October 6, 2017 at 2:49 pm #1393820

Albert

Tell us what you are trying to do?
I’m configuring AMP pages for my website.

Is there any documentation that you are following?
hidden link

Is there a similar example that we can see?
hidden link
hidden link

What is the link to your site?
hidden link
hidden link
hidden link

Detailed Explanation:
I’m installed “Better AMP” plugin and configured my website completely for the same. AMP is working fine on Default language website. That is: hidden link
But when I am trying the same on Tamil and Hindi URLs it is not working. When we click on Tamil and Hindi AMP URLs it is redirecting to English Language Normal page.

Tamil AMP URL: hidden link
Hindi AMP URL: hidden link

Please help fixing this issue.

October 6, 2017 at 2:54 pm #1393837

Albert

Is there any redirection issue?

If you want I can send you the AMP plugin package to you guys. How do I send a attachment in here?

October 7, 2017 at 7:44 pm #1394471

Albert

Hello, Can anyone care to respond?

October 9, 2017 at 3:56 pm #1395647

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello.

Sorry for the delay in responding. We are completely loaded in the queue and trying to catch up with inqurires.

1. AMP Plugin
If AMP is not currently on our list of plugins that are compatible with WPML, then we would indeed appreciate a copy of the AMP plugin to try it out ourselves. It would be helpful for you to also include basic instructions on how to set it up AS WELL AS steps to replicate a simplified case on a fresh WordPress install.

Can you please do this?

I am opening the private area for you to include a downloadable link where to get the plugin from. Please use a file sharing service like Dropbox, Fileshare, WeTransfer or similar.

2. Clarification
You wrote: "..When we click on Tamil and Hindi AMP URLs it is redirecting to English Language Normal page..."
I understand this to mean that when you change languages from an AMP page, the URL is not able to formed.

For example understand that when you attempt to visit:
hidden link
Instead of seeing a page that is similar to the format of this URl in Tamil:
hidden link
You are being redirected to this:
hidden link

Correct?

3.Technical Information on you environment

Could you please provide information about your environment by following thsese steps: http://wpml.org/faq/provide-debug-information-faster-support/

Thanks

October 10, 2017 at 8:57 am #1396358

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello.

1. Plugin
I have scanned the documentation and I can see that this plugin is "exclusive" to the theme. e.g. it is designed to be used with your theme and not with others.

2. AMP functionality with WPML (in general)
I´ve investigated internally and I can see that we have some challenges, in general, with implementations of AMP. In some cases it works with WPML but in concrete cases, like multicurrency operations, it may not.

For YOAST SEO, there seems to be a glue plugin to make the more current/popular plugin work:
hidden link

3. Your case - some Diagnostic Steps
For your case, in particular, I would suggest that we do the following tests to see if the problem is with the way it is working with the index.php as opposed to a static page.

3.3 Does the redirection still happen if you temporarily deactivate all non-WPML plugins (except the ones required for your theme basic functionality)

3.2 Could you change the front page from "Latest posts" to a simple "Static page" (translated to all languages) that is not using VC components of any kind?
Does the redirection still happen?

3.3 Would you also check if the same behavior happens if you temporarily change your URL format to use language by parameter?
Remember to regenerate the permalinks when you change it...and also again when you change the URL format back to its original format.

4. Staging site
It would be much easier if you could provide a staging site. We normally use DUPLICATOR for this on our own servers. Do you know it? It is free and generally easy to use to make a quick replication of your eviornment.
Here is a video fyi:
hidden link

I wait for your responses especially for points 3.
Thx

October 10, 2017 at 10:03 am #1396472

Albert

Hi,

Thanks for the response.

1. You can use this AMP plugin with any theme. No License key required.

2. I will try this addon.

3.1 Yes. still happens.

3.2 I don't like VC plugin and I'm not using in this website also. ok. As you said, I've created one test page.
hidden link
hidden link
hidden link

But now when I visiting this page's Tamil and Hindi pages, it is now redirecting to English page.
That is,
When I visiting hidden link it is redirecting to hidden link

3.3. I will do this later in the night time.

Yes. I know Duplicated plugin. But I'm afraid, I can do this without FTP details for creating replica.

October 13, 2017 at 11:06 am #1400187

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello again.

I installed the plugin and could replicate the problem with the Twenty Seventeen theme. Since this plugin is not yet listed in the current group of compatible plugins, I will need to escalate this to our compatiblity team.

Please note that the amount of time required for a plugin to become compatible depends on the willingness and availability of the plugin authors. This can take time. Normally, we will extend an invitation to the authors to join our GoGlobal program where they will receive support to integrate with the WPML architecture.

It is not our policy to change code that is not written by us. For this reason, the final fix needs to be delivered to you by the plugin author. Once the plugin is deemed compatible, then we will include it in the list of compatible themes/plugins along with the fully tested version number.

I hope this helps you with your planning. Do you have any other question before I escalate this to our compatibility team?

Kind regards

October 13, 2017 at 6:41 pm #1400699

Albert

Please go ahead. We need this fix ASAP. Because, AMP is another ranking factor.

For now I will disable AMP on other language pages.

October 17, 2017 at 11:25 am #1403234

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Escalated to Compatibility for further action.

October 31, 2017 at 7:17 am #1416380

Albert

Any update? Author responded?

October 31, 2017 at 7:43 am #1416399

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

Yes, they have reached out to the plugin author(s) and here is the note that they have placed in the work ticket:
====================================================
Typically the AMP URL will have /?amp=1 or /amp appended to it.
But this plugin is trying to build AMP urls by placing /amp/ in front of the path instead.

This doesn't work with WPML well when we use "language per directory" because we try to put the language folder in front of the path too.

In other words, both plugins are fighting for the same space in the URL and it seems WPML is winning: hidden link is working for me.

The quickest solution is to change URL format to something different than "Language per directory".

Another solution would be to use an AMP plugin that appends /amp/ to the URL instead of prepending it:
https://wordpress.org/plugins/amp/

I am not sure what the proper solution would be here:
Should /amp/ be in front?
Or should the language folder be in front?

I think we would have to reach an agreement with the author.
=====================================================

The author was contacted on 24 October here.
https://wordpress.org/support/topic/compatibility-with-wpml-49/

I do not see any evidence of a reply from them. Perhaps you can contact them as well?

November 6, 2017 at 6:49 am #1421342

Albert

Hi, Looks like Plugin Author responded in WordPress support thread with a fix. https://wordpress.org/support/topic/compatibility-with-wpml-49/

Can you check?

November 6, 2017 at 8:01 am #1421397

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Thanks for that news!

I´ve forwarded your message to the compatibility team. I hope to have some news for you soon.

November 6, 2017 at 3:16 pm #1422106

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Just updating here with news from comaptibility:

We tried with this hidden link and it worked much better.
This is what we found:
- pages, posts and archive pages work
- the home page still doesnt work though
- the url in the source code is incorrect, it says:
<link rel="amphtml" href="hidden link"/>
when it should be:
<link rel="amphtml" href="hidden link"/>

We will look for a fix and share with the author.

November 7, 2017 at 11:18 am #1423013

Albert

Awesome. Happy to see some progress.

The topic ‘[Closed] Language URLs are not working in AMP Pages’ is closed to new replies.