This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: It is not possible to translate weekdays strings on the ListingPro Theme´s account section.

Solution: Please apply the following fix to the file, by changing the respective code line:

wp-content/themes/listingpro/include/single-ajax.php line 1175:

'x' => date_i18n("l", $singleDay),

Relevant Documentation: https://codex.wordpress.org/Function_Reference/date_i18n

This topic contains 13 replies, has 2 voices.

Last updated by hocineS 5 months ago.

Assigned support staff: Andreas W..

Author Posts
April 28, 2019 at 3:21 pm

hocineS

Hello

I have some language mismatch on the site, and I went through many articles and couldn't find a fix. When a user logs in select french and go to dashboard, the if you select EN SAVOIR UN PEU PLUS on the dashboard you get the listing activity chart which displays the days in english even though they are actually translated, and if you select listing you have thsi word Publsih which never get translated. And if you go to dashbaord again and select Englsih this time then go to listings on the published listing go Edit, a new tab opens up and you get the listing all in english except the opening hours in which the days are displayed in english see the attached snapshots and the this video :

hidden link

What ever you do do not activated the main theme, always keep the child active, thank you

April 29, 2019 at 4:38 pm #3705635

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello

Thank you for contacting WPML Support.

Please install the ListingsPro Theme and its plugins to the following test site on order for me to test it for compatibility.

One Click Login:hidden link

Further, could you please increase your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 512M
WP Memory Limit 64M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000.
You can find the php.ini file on your server inside the folder for your currently used PHP version 7.0.33.

In case of any doubt please contact your hosting provides and ask for assistance

Please do not forget to leave me a short notification once the theme and its plugins have been added to the test site.

Kind regards
Andreas

April 29, 2019 at 8:37 pm #3706567

hocineS

Hello

I set up and activated the theme and wrote to the hosting service provider about the memory and the php.ini file, they will fix this very quickly.

Thx

April 30, 2019 at 6:53 pm #3714373

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for setting up the theme on the test-site.

I have tested the translations and I was able to find strings for many sections of the theme.

The only strings I was not able to translate so far are the weekdays, as it seems that they are not proper coded in the theme template. In order to translate them they will need to be wrapped in a GetText Call.

More information here:
https://wpml.org/faq/language-setup/

I would like to invite you to check out the test site. I have added many strings from the option "translate texts in admin screens" to String Translation. I am using the theme in default language English. By using the String Translation "Exact search" option I was able to locate literal strings and translate them. I would like to onvite you to do some testing on the provided site:
One Click Login:hidden link

Anyhow, there may be strings for that this is not working.
You will indeed find weekdays on String Translation, but they are referring to the domain "default", while there are not any strings for the domain "listingpro". What I am trying to say, is that most likely these are not the strings of the theme.

I would like to ask you kindly to contact the theme author's oin regards to the issue, as they will need to apploy changes to their theme's template files, in order for WPML to be able to translate the whole content.
Please, invite them to join our GoGlobal Program for working tiogether on making WordPress multilingual ready.
https://wpml.org/documentation/theme-compatibility/go-global-program/

Please take note, that we can not have any influence from our side to make each string appear for translation. The changes will need to be made by the theme author or by yourself, using a Child Theme with GetText call configurations for each string.

Kind regards
Andreas

April 30, 2019 at 9:19 pm #3714971

hocineS

Hello

I wrote to the theme author support and explained all this issue, and this was theire reply:

<<Actually we have shown the data in the format which support worpdress settings in wp-admin. To work with wpml, you need to ask their support that how the core wordpress settings week days will translate in wpml. It is relevant to them so they will guide you better. At our end, we have added all possible code for translation support.>>

Thanks

May 2, 2019 at 4:49 pm #3727239

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you very much for the provided information.

I have investigated the issue once more and sadly the strings for weekdays are not translatable for the English version. I further, was not able to locate any strings related to these weekdays inside of the admin text theme options.

The issue has been escalated to our compatibility team in order to investigate and to find a solution. I will contact you as soon I received feedback.

Thank you for your patience.

Kind regards
Andreas

May 2, 2019 at 8:24 pm #3729047

hocineS

Hello Abdreas

I wrote to the theme author about this issue and I am trying to push for a complete compatibility with you guys, and this was their reply:
<<<For days in edit listing it will be so simple if they reply you answer of the question I am asking in the screenshot. See bellow:
hidden link

If they tell you about it and you translate strings of the drop-down I shared, it will be solved automatically.
For more insights days we have add a code in
wp-content\themes\listingpro\assets\js\single-ajax.js

May 2, 2019 at 9:17 pm #3729295

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

In fact in our String Translation module there are appearing twice strings for each day, which are registered on two different domains. One is called "default", the other strings are based on the domain listing_pro settings. Those domains are hardcoded into the theme´s template files:

Example: <h2><?php _e('Links','theme-text-domain'); ?></h2>

The strings are apopearing on WPML and are translated but for some reason are not showing up on front end. It might be that the issue is solvable on our side.

Our compatibility will be investigating and work on a solution. I will get back to you as soon I received feedback.

Please let me know if changing the wp-memory limit and the value for max_input_vars helped in regards to the issue once you received feedback from your host.

Kind regards
Andreas

May 2, 2019 at 9:39 pm #3729317

hocineS

Hello Andreas

All the wp-memory limit and the value for max_input_vars have been fixed b y the hosting provider. And I wrote again to ListingPro support with your feedb ack and they will respond tomorrow, I let you know.

Thx

May 9, 2019 at 2:16 pm #3776991

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello

Thank you for your patience while we been working on the issue.

For some reason the sandbox test site which we used for testing expired. Could you please install the ListingsPro Theme again to the following test site on order to work on a fix for the issue.

One Click Login: hidden link

Please leave me a short nofification once the theme is installed.

Kind regards
Andreas

May 10, 2019 at 1:38 pm #3785071

hocineS

Hello Andreas

It's all set up and working, but this test site will also expire in about 7 days

thx

May 10, 2019 at 2:43 pm #3785597

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi!

Thank you very much for installing the components to the sandbox.

I am currently creating a Duplicator package which will be saved on our server. This way the install will no longer expire for at least one month.

I will get back to you as soon I receive feedback about a workaround and fix for the issue.

Kind regards
Andreas

May 13, 2019 at 6:20 pm #3801131

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Our compatibility team located an issue with the theme and provided a fix. I was sadly not able to apply it for testing reasons, as the FTP access to your server is denied.

Please apply the following fix to the file, by changing the respective code line:

wp-content/themes/listingpro/include/single-ajax.php line 1175:

    'x' => date_i18n("l", $singleDay),

Let me know if this sovled the issue.

Kind regards
Andreas

May 14, 2019 at 5:59 pm #3809791

hocineS

My issue is resolved now. Thank you!