Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by Weeboo 2 years, 7 months ago.

Assigned support staff: Bruno.

Author Posts
February 6, 2018 at 3:29 pm

Weeboo

I am trying to: Translate pages after update

Link to a page where the issue can be seen: hidden link

I expected to see: translated pages

Instead, I got: Languages missing

This thread is where I started, but it seems that the issue is still not resolved:
https://wpml.org/forums/topic/languages-missing-after-update/

After all of this everything looks ok, but the translation editor is not working and the I open this new thread:
https://wpml.org/forums/topic/blak-page-on-translation-editor/

I have added now the code mentioned in the previous thread and when I save the translation for the home page, for example, the languages are missing.

February 8, 2018 at 7:02 pm #1512033

Bruno

Hi,

Thank you for contacting us. Please, my sincere apologies for the delay in answering. This is not usual in this forum.

Please follow the steps below:

- Make sure you have the backup of your site
- Click on the WPML > Support > Troubleshooting
- Look for 'Clean up'
- Check the "This operation will reset WPML's language tables and reinstall it. Any custom languages that you added will be removed." option
- Click on the "Clear language information and repopulate languages" button
- Click on these buttons:
-- Clear the cache in WPML
-- Remove ghost entries from the translation tables
-- Fix element_type collation
-- Set language information
-- Fix post type assignment for translations

This issue appears to be happening because the language table is incorrect. By following the steps above, this should fix the issue.

After following these steps, try again to save the homepage and see if the problem persists.

Thank you.

February 9, 2018 at 3:16 pm #1513069

Weeboo

Thanks a lot, it worked!