Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

El problema: - Los idiomas han desaparecido de WPML > Idiomas.

La solución: - Desactiva todos tus plugins WPML. - Bórralos y cárgalos de nuevo. - Ve a WPML > Soporte. - Solución de problemas - Da click en el botón para recrear tus tablas. - Ve a WPML > Idiomas y escoge Inglés y Español. Tal vez necesites utilizar la consola de tu navegador para acceder al HTML y borrar el atributo disabled="disabled". - Guarda las opciones.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 3 voices.

Last updated by Andrés 2 years, 10 months ago.

Assigned support staff: Andrés.

Author Posts
January 18, 2018 at 8:43 am

Weeboo

I am trying to: update to the latest version

Link to a page where the issue can be seen: hidden link

I expected to see: Language switcher and widgets

Instead, I got: Language switcher and widgets are missing. If I go to WPML --> languages and the go to Edit languages, no language appear.
The site is a woocommerce with many of the WPML plugins included. It was working fine before update and also now, if I go to WPML --> Support everything is ok.

January 20, 2018 at 3:17 am #1490535

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

When you go to WPML->languages the page is empty or are there just no languages showing at all?
- were you using custom languages before ?

Please go to WPML => Support , and click on "Troubleshooting" while in the Troubleshooting page please perform the actions. (specifically "set language information" but i recommend performing all of them"

January 20, 2018 at 9:57 am #1490600

Weeboo

I did what you suggested but I think has been worst. Now I can't find the pages or products in the second language (es). In the live version you can see how it was before updating. hidden link. All this happens while updating WPML plugins.

January 20, 2018 at 10:00 am #1490602

Weeboo

Also updated Woocommerce before WPML.

January 22, 2018 at 2:25 pm #1492122

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello there,

As Bobby is not available I would like to take care of your case.

For support rules we are able to handle only one issue at the time. This help us to bring you a better service and also help other users to find all the information here exposed. For that reason I have to kindly ask you to open a new thread if you need further assistance, you can assign it directly to me. In that way you don't have to wait and we can continue working on it.

1. Regarding to your languages missing as your credentials don't work, could you add a screenshot of your WPML > Languages page, so I can better understand your issue?

2. It would be good if you can provide me the WordPress debug.log (not WPML debug informations).

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way, because sometimes the logs are long and create a complete mess in discussion).

Regards

January 22, 2018 at 4:56 pm #1492455

Weeboo

ok, here you have:
https://pastebin.com/utMGJfib
Thanks

January 22, 2018 at 5:06 pm #1492469

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Thanks for your debug information. From there, I can see several notices regarding WPML.
However, I'm not sure yet to understand your issue, that's why I asked you a screenshot of your situation at WPML > Languages.

Could you uninstall and install your WPML package manually?

============================
==>Backup your website and database <==
============================

-Deactivate and delete the “installer” plugin (if you have it).
-Deactivate all WPML plugins.
-Login via FTP to your wp-content/plugins/ folder.
-Delete all WPML folders.
-Go to http://wpml.org/my-account/downloads/ and download the latest WPML Multilingual CMS Plugin, then extract it.
-Upload the plugin via FTP to wp-content/plugins/ folder.
(alternatively you could upload the .zip folder using Dashboard > Plugins > new > upload)
-Activate the WPML plugin via WP Dashboard > plugins.
-Complete the setup, if needed.
-Register WPML for your site (at the end of setup, click on “generate key” button).
-Navigate to Dashboard > Plugins and locate WPML Multilingual CMS.
-Click on the blue link that says “Registered”.
-Download and activate all needed WPML AddOn Plugins.

This should not generate any problems.

In case you want to register WPML for your site manually please make sure to enter the naked URL of your site in wpml.org (something like hidden link)

In the extreme case, please try to register with all non-WPML Plugins deactivated.

Please let me know if this works,
Andrés

January 23, 2018 at 12:21 pm #1493744

Weeboo

Hola Andrés, he eliminado los plugins y los he vuelto a instalar y registrar tal como me indicas. El problema persiste. Ya que veo que hablas español te lo explico de nuevo.
La versión real es hidden link, y es de la que se ha partido para actualizar la copia con la que estamos trabajando en este ticket, hidden link. Por ello lo mecionaba antes, para que puedas ver que en la versión de partida funciona.
Al actualizar Woocommerce y WPML es cuando aparece el problema. Desaparecen los idiomas. No se si tendrá que ver, pero inicialmente se trabajaba con Polylang y se migró a la versión de WPML que está ahora funcionando en live.
Ahora la web staging está en modo debug y aparecen los errores que adjunto en la captura. También he actualizado los datos de acceso para que puedas acceder con las credenciales que se indican al principio.
Gracias

January 23, 2018 at 3:37 pm #1494109

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hola,

Claro, podemos seguir en español.

¿Me podrías dar las credenciales de tu sitio web de prueba, de esta manera podemos dar un vistazo a tus ajustes, así como los pasos necesarios para reproducir este comportamiento?

Para esto, debes poder ver una forma protegida en la parte inferior de este tópico. (Te pide hacer un backup y un + Aviso legal). Una instalación de test es preferible y nos haría mucho más fácil hacer una evaluación. En cuanto tenga más información te lo haré saber

Importante: Haz un backup completo de tu sitio. Puedes usar un plugin como Duplicator para este propósito. Mira en: http://wordpress.org/plugins/duplicator/

Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

Privacidad y seguridad al proporcionar información de Debug para soporte:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

January 23, 2018 at 4:20 pm
January 23, 2018 at 5:31 pm #1494316

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Perfecto, ahora que tus credenciales funcionan he podido ver el problema. Inicialmente creí que te faltaban tablas icl_ (las tablas usadas por WPML), sin embargo cuando accedo a tu base de datos veo más de 88 en lugar de 22. ¿Acaso tenías un multisitio instalado anteriormente?

Adicionalmente veo que tu sitio se tarda cierto tiempo en cargar. ¿Podrías reinstalar la versión en producción? Me gustaría hacer el update y ver si se produjo un error debido a problemas de rendimiento.

Saludos

January 23, 2018 at 7:45 pm #1494480

Weeboo

Ok, ya lo tienes. No había multisitio, lo único raro lo que comenté de la migración desde Polylang

January 24, 2018 at 8:02 am #1494864

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Gracias por la aclaración. Esto llevará más tiempo de depuración, por lo tanto lo tendré que referir a nuestro 2nd tier.

Te tengo al tanto de cualquier novedad.
Saludos

January 25, 2018 at 12:40 pm #1496853

Weeboo

Vale, gracias, me mantengo a la espera

January 30, 2018 at 8:17 am #1501129

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hola,

He tenido un primer feedback de nuestro equipo de compatibilidad.

Como tu sitio no está funcional en este momento:
- Desactiva todos tus plugins WPML.
- Bórralos y cárgalos de nuevo.
- Ve a WPML > Soporte.
- Solución de problemas
- Da click en el botón para recrear tus tablas.
- Ve a WPML > Idiomas y escoge Inglés y Español. Tal vez necesites utilizar la consola de tu navegador para acceder al HTML y borrar el atributo disabled="disabled".
- Guarda las opciones.

Nota: es importante que utilices las últimas copias de WPML ya que con las versiones anteriores no era posible correr las opciones de depuración debido a un conflicto JS.