This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 2, 2018 at 3:46 pm #2782173

kalinL

When we select a different language it reverts back to English once we try to explore different pages. Example, Click in the Russian site, we need the other pages from the nav bar to stay in Russian.

October 3, 2018 at 3:42 pm #2785108

kalinL

We found a new issue as well. Our our homepage, hidden link can't translate this section

October 4, 2018 at 7:40 pm #2788686

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Have you translated the pages to Russian? The pages will need to be translated or duplicated in order for the language switcher to work correctly. If the pages have been translated and it still is not working, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. With these settings, is the issue resolved?

Lastly, which part of the homepage are you unable to translate? Perhaps a screenshot of the section would help me better understand.

To ensure the quickest and most accurate support, please provide your debug information so that I can get a look at some of your configurations. We have an excellent article on how to located here: https://wpml.org/faq/provide-debug-information-faster-support/.

NOTE: Please be sure to check the box to indicate you can provide debug info and paste your debug info in the debug field provided, and NOT in the general response field.

October 5, 2018 at 1:46 pm #2790960

kalinL

Attached is a screenshot of the section we can't find to translate. No, not all content is translated yet.

October 5, 2018 at 7:28 pm #2791578

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I did not see an image attached. Can you please send the screenshot?

Also, if the page that you are trying to access have not been translated, this is likely why the are returning to the default language. Please tell me specifically which link you are clicking in the menu that has been translated and is returning the wrong language.

October 8, 2018 at 4:46 pm #2796963

kalinL

I'm having issues uploading an image here. Can I email it?

October 8, 2018 at 6:15 pm #2797085

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

You can upload the image to Google Drive or Dropbox and share the link in the next reply. That will be better than email, just in case we need other supporters to take a look at the ticket. Thanks!

October 9, 2018 at 1:05 pm #2800058

kalinL

hidden link here

October 9, 2018 at 3:14 pm #2800731

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It looks like this is content that is coming from your theme options. Is this correct? If so, it is likely stored in the admin texts. Can you please go to WPML > String Translation and scroll down to the bottom of the page and click on the link "Translate texts in admin screens »". Then, scroll through that page and see if you find the the string. If so, tick the checkbox and click Apply to add it to the String Translation table. Now you can go back to WPML > String Translation and you should see the string added there.

If this does not resolve the issue for you, I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 9, 2018 at 10:38 pm #2802314

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Those credentials are not allowing me to log into your site. Please edit your previous post as needed to update the correct credentials. Thanks!

October 10, 2018 at 1:26 pm #2804449

kalinL

Please check again. I tested the login.

October 10, 2018 at 2:29 pm #2804778

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks, I was able to login but when I view the page "Homepage", I don't see this content anywhere. Please tell me how and where this block of content was created so that I can see where it exists and hopefully figure out how to translate it.

Also, it looks like perhaps this was created with the Cornerstone page builder. If so, please see this currently known issue: https://wpml.org/errata/cornerstone-shortcodes-arent-rendered-in-the-translated-pages/

The current workaround is to use manual translation to edit the translated content manually. To do this, you can use the admin language switcher to change languages once you are editing the page, or you can go to WPML -> Settings and change to manual translation.

Please let me know if you need any further assistance and I will be happy to help.

October 10, 2018 at 5:51 pm #2805378

kalinL

Yes, Cornerstone was used. Let me try your suggestion.

October 10, 2018 at 6:29 pm #2805427

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Okay, thanks. Please let me know the results.

October 10, 2018 at 10:03 pm #2805915

kalinL

Still was not able to edit. We have another question as well

If possible, would like the language selector to be in corresponding languages. Russian to be in Russian, German in German, Spanish in Spanish. Can’t find where that part of the menu is located.