This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 7 replies, has 2 voices.

Last updated by marijog 1 week, 5 days ago.

Assigned support staff: Bobby.

Author Posts
September 27, 2019 at 7:09 pm #4656459

marijog

Tell us what you are trying to do?
I can not find where is mistake?
Is there any documentation that you are following?
in console I find: Uncaught ReferenceError: jQuery is not defined
Is there a similar example that we can see?
I try instaling from beginning, but always the same :-/
What is the link to your site?
hidden link

September 28, 2019 at 12:43 am #4656959

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

When WCML is activated the following script is inserted in your HTML as you can see in my screenshots of your source code, which essentially is pushing the site down causing CSS problems.

If possible please contact your theme provider as the script is provided by them and I don't believe it should be being added before the header which is what is causing this issue.

Also, the reason why the issue is resolved when you downgrade to the older version of WPML is that the main WPML plugin is at the latest version and installing an older version of WCML will cause WCML to not be activated.

The theme author has most likely introduced this new script in their latest version of their theme, as I see that you are using the latest version.

Let me know their feedback please.

September 30, 2019 at 11:47 am #4664229

marijog

Hello there.

I installed the theme from the beginning, made everything and there were no errors. After that I installed WPML plugins and started translating.

Again, I got the same error with the WCML plugin as before. There was definitely no error before, until I activated this plugin.

This is notice in inspect console:

September 30, 2019 at 11:49 am #4664255

marijog

...as You can see, icons are moved up and errors occur on the smartphone too?

This is the domain on which the topic resides:

hidden link

September 30, 2019 at 5:45 pm #4666963

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

The credentials to the test site are no longer working.

Your theme at its latest version has introduced a new script that is enabled once WPML + WCML are enabled on your site.

This script is coming from your theme and not WCML. The reason it happens once WCML is activated is that once your theme detects WCML it executes the script.

As my screenshots were not successfully uploaded please do the following the see what I am referring to:

1. Right-click on your home page and "view page source"

2. Inspect the page source and notice that above the !DOCTYPE and header there is no script

<!DOCTYPE html>
<html lang="bs-BA" class="no-js">
<head>
    <meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1.0, user-scalable=no">
    <link rel="profile" href="<em><u>hidden link</u></em>">
    <link rel="pingback" href="<em><u>hidden link</u></em>">
    <title>EuroExpressCars &#8211; Rent-a-car agencija</title>

3. Now go back to plugins and enable WCML
4. Visit your home page and right click to "view page source"
5. Inspect the page source now and notice the script above !DOCTYPE

This is why your CSS is off because the script above the header is pushing everything else down including your HTML.

Please contact your theme provider and let them know of this issue as this script is introduced by your theme every time WCML is enabled.

Let me know their feedback please.

October 7, 2019 at 8:33 am #4705453

marijog

Hello wpml...

I have problems again. I deleted everything and installed everything from the beginning.
I installed wp, wp theme, built the site, installed wpml and did the translations. I used Advanced Translation Editor, but I also had to make some parts with Classic Translation Editor.

While translating I had some problems with some products (Add-ons), but when I changed the default language, all the links cracked? Now all links are directed to the default language, although the links are to another language? (atach 1)

All core pages: shop, policy, cart ... etc are in one language only, so they always redirect to them. If I change to another language, then the setting of that page is lost in the previous one? (atach 2)

I did all this not including multi-currency mode, because when I turn it on, I again have a problem that I described earlier in my last mail - "jQuery is not defined" , and the css breaks down and I can't even finish booking the vehicle.

Here is link to web page: hidden link

username: \
password. \

Please, do you can check this?

I've been trying to handle this for a few days now and I don't know anything anymore. Everything is a complete mess now??? :))

Thanks.

October 7, 2019 at 9:59 pm #4710871

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

As we try to keep each ticket to 1 issue, if possible please open a new ticket regarding the new issue you are experiencing.

Regarding the original issue of this ticket, please review my last response as it is related to the custom script that has been added by your theme.

Your theme detects when WCML is enabled and adds an additional script above the HTML pushing everything down, causing problems with the CSS, which is why I have redirected you to the theme's support.

This is not caused by WPML's code, the theme simply adds this script once it recognizes WCML activated on your site.

October 8, 2019 at 8:16 am #4713087

marijog

Thank you!