This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The latest WPML Update breaks the Language Switcher on the header section of the Kallyas theme.

Solution:

It seems that it was an issue with the Kallyas theme. It was not updated to its latest version. It was on version 4.16.3, and I've updated it to the latest 4.17.1. Then I also updated WPML and its add-ons to the latest versions. And the Language Switcher is showing on the header section.

This topic contains 10 replies, has 2 voices.

Last updated by Itamar 5 months ago.

Assigned support staff: Itamar.

Author Posts
April 30, 2019 at 9:52 pm #3715053

sarahA-6

I am trying to: Update WPML to the latest

Link to a page where the issue can be seen: on our hidden dev site

I expected to see: Working plugin

Instead, I got: The language toggler in the header disappeared

We have held back on upgrading our WordPress to 5.X until we have ironed out our transition plan. So we're still on WP 4.9.8. The latest WPML update breaks when I update the WPML CMS Nav plugin. The language toggling dropdown in the header disappears.

May 1, 2019 at 10:18 am #3717519

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've tried to see if the problem is also happening on a clean WordPress installation with the latest version of the WPML CMS Nav add-on and the latest version of WordPress. But I cannot reproduce this issue. You can see my test site here.
hidden link

Please correct the following and see if it helps.

1. Clear the cache on your site and check if the issue persists.

2. By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 64M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above.
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important in this case is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if they help?

If they do not help, please share with me the access to your site and explain to me where I can see the issue.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

May 5, 2019 at 1:58 pm #3742919

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

I've checked a few things on your site and here are my finding and ways to proceed to debug the issue.

1. WP Memory Limit

The WP Memory Limit has not been raised on your site. I can see that in WPML -> Support. Please see the attached screenshot wp-mem-not-rsd.jpg. I do not think that the method that you have mentioned is the correct method of raising the WP Memory Limit. You can read more about it in the WordPress documentation here.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
Please increase it as I'm mentioned or get the help of hosting company. You can also share with me the FTP credentials, and I'll try to help you with that. For this, I'll enable a private message for the next reply. Please note that the raising of this value might be limited by the hosting service directly on the server.

2. No Language Switcher
Currently, WPML is not updated on your server, and I didn't update it. But still, there is no Language Switcher on your site. Please see the attached screenshot no-ls.jpg I think that the reason that you still saw Language Switcher was that you saw a cached site. I've cleared the cache on your site from the 'Clear cache' option at the top admin bar. Please note that while developing a site or making any changes it is important to disable any cache.
By the way, the Language Switcher location is set in WPML -> Languages and not in the theme option as you specified. Please let me know if you remember setting it there or if it was not you who initially added WPML to this site.

3. Broblem - No languages
What I did find was that there seems to be another major problem on your site. When I go to WPML -> Languages, I see that there no languages configured on your site. Please see the attached screenshot no-languages.jpg. I can see this problem also if I go to Pages -> All pages. Over there the is a list of all the pages in all the languages, but there is no option to view the pages by languages. I cannot know what has caused this error. But here is what you need to do to try and fix it.

A. Take a backup of the DB of your site.

B. Go to WPML -> Support -> Troubleshooting (link).

C. Once on the troubleshooting screen press the following buttons and check if it helps.
Press each button at a time and wait for the process to complete.

- 'Disable cache for language switcher templates'

- 'Clear language information and repopulate languages'
Please note that for this option any custom language that you have made would be erased.
Did you create a custom language on your site?

- 'Clear the cache in WPML'

- 'Remove ghost entries from the translation tables'

- 'Fix element_type collation'

- 'Set language information'

- 'Fix post type assignment for translations'

- 'Assign translation status to duplicated content'

While you are in this section you can also try the other buttons.

Of course, you shouldn't try the WPML reset option.


*** Please make a backup of your database before using this.**

Please remember to deactivate the cache while making all those changes.

Thanks,
Itamar.

May 7, 2019 at 6:40 pm #3761285

sarahA-6

My mistake on the memory limit. It is correctly set now.

It's perplexing that we're seeing these issues, such as no switcher, no languages, etc. I had unregistered and re-registerd the WPML suite of plugins, since it doesn't seem to want to upgrade unless I do that. My presumption was that because this is a copy of our site, and not the live one, it carries the registration of the live site URL (eos-gnss.com) and needs to be re-registered for the test URL we're on (test1.eos-gnss.com). Could de-registering and re-registering cause the settings (affecting languages and switcher) to get dropped?

Also, because this is not our live site, but a test dev copy, I'd like to see if we can sort out the cause, rather than just fixing the db downstream with your tool, since we won't be using this db on the live site, anyway. Also, it sounds like we'd lose a lot of important language data across our multiple hundreds of posts if we used this process for our db going forward?

For clarity's sake, our normal update process looks like:

-Copy our most recent daily snapshot of the live site from BlogVault to test1.eos-gnss.com
-De/Re-register WPML to work on test1
-Update WPML (and any other plugins) on test1
-Check site to make sure things are working properly
-After confirmation, go to live site and run updates there
-Clear out database and public_html for test1

So this is just a copy we run off to test. We never fold these files or the database back into the live site. Whatever the problem is, it's not occurring on the live site, since we can see languages, and the language switcher on there just fine.

What we're currently looking at on test1 should be a straight copy, plus the aforementioned de/re-registration of WPML. I can try another fresh copy, if needed, and turn off the caching, but leave the registration untouched, if that could help us.

May 9, 2019 at 6:43 pm #3778865

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and sorry for the late reply here.

You ask: "Could de-registering and re-registering cause the settings (affecting languages and switcher) to get dropped?"

No, I don't see how the registration issue can be connected to those problems that you have on your site. The only thing that registering the site enables is the automatic updating of WPMl and its add-ons. In any case, you can always manually install or update WPML by loading the latest versions from your account on our site here. https://wpml.org/account/downloads/

You ask: "Also, it sounds like we'd lose a lot of important language data across our multiple hundreds of posts if we used this process for our db going forward?"
No, the process supposes to fix those problems on your site. In any case, if things will not work as expected, it is highly essential to take a backup of the DB before proceeding with the troubleshooting options.

You mentioned: "Copy our most recent daily snapshot of the live site from BlogVault to"
It might be, and I've seen things like that happen, that the copying/migration process from BlogVault to the test site/server didn't work correctly and thus all those issues occurred. I'm also not familiar with the BlogVault plugin/service, and we also might be looking here on a compatibility issue with WPML. I usually use the Duplicator plugin to duplicate/copy my sites, and in most cases, there is no problem migrating sites that use WPML with the DUplciator plugin. https://wordpress.org/plugins/duplicator/

I hope that this information is helpful to you.

Regards,
Itamar.

May 10, 2019 at 3:12 pm #3786063

sarahA-6

I have just refreshed the site copy, and cleared caches, as well as disabling the cache plugin completely - just to clear up any questions regarding that. The language changer dropdown is still showing. Your access info is the same as before. I have attached a screenshot to confirm the language changer.

May 13, 2019 at 8:51 am #3796223

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Could you please redefine the problem that you are having on your site?
I'll explain now why I'm asking this. In the beginning, you wrote: "Latest WPML Update breaks nav on WP 4.9.8," and you have added: " The language toggler in the header disappeared". But now you say that the Language Switcher is showing. You also attache a screenshot that shows that, and also I can see that it is showing on your site. So I'm confused and would like to ask you if you, please tell me what the problem that you currently have on your site is?

It is also important for me to tell that you must update WordPress itself to its latest version and, if not done yet, also WPML and its add-ons must be updated. I can see that WordPress is not updated. We cannot continue debugging this issue when you are using an old version of WordPress.

I've accessed your site again but currently, it the user that you have provided me with, is not an administrator, so actually, I can not see or check anything. Please see the attached screenshot. Please correct this.

Thanks,
Itamar.

May 13, 2019 at 9:32 pm #3801743

sarahA-6

I apologize fir any confusion over this. The issue remains the same.

From the original issue description:

"We have held back on upgrading our WordPress to 5.X until we have ironed out our transition plan. So we're still on WP 4.9.8. The latest WPML update breaks when I update the WPML CMS Nav plugin. The language toggling dropdown in the header disappears."

As to the confusion over the upgrade breaking things, and the fact that the development copy of the site on test1 is not broken... that's because when I originally filed the issue, I had copied the latest backup of the site to test1 to test doing updates. When I ran the WPML updates, the language selector disappeared. In our initial go-round, it seemed that it was a challenge for both of us to troubleshoot what had gone wrong AFTER the break happened. So I rolled the test1 copy of the site back to an unbroken (and un-upgraded) one. Now, you can feel free to see how the language selector is set up, then try updating WPML, and see how it breaks. I though that would give you much more insight into what was going on.

Regarding WordPress versions: We are not yet able to upgrade WordPress until we have some other, unrelated issues resolved. If the core issue is that the current WPML is just not compatible with WordPress 4.9.8, then I suppose all of our looking and testing are moot. We could have established that at the outset. If however, that doesn't prevent us from continuing, then the test1 site is ready for you to try an update on WPML (but not WP). I have made your user an admin - apologies for that oversight.

May 14, 2019 at 3:28 pm #3808675

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've fixed this issue on your site. It seems that it was an issue with the Kallyas theme. It was not updated to its latest version. It was on version 4.16.3 and I've updated it to the latest 4.17.1. Then I also updated WPML and its add-ons to the latest versions. And the Language Switcher is showing on the header section. Please see the attached screenshot ls-header-ok.jpg. I didn't update WordPress itself. BTW, the Language Switcher is set on the theme options Kallyas Theme Dashboard -> General Options. Please see the attached screenshot kallyas-to.jpg

Could you please confirm that this issue is resolved/

Thanks,
Itamar.

May 14, 2019 at 9:09 pm #3810705

sarahA-6

Thank you very much for your assistance! I can confirm that this indeed resolves it, and I have implemented it on our live site now.

May 15, 2019 at 10:35 am #3815011

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great, I'm glad that it is solved now!
Good luck with your web projects 🙂
Itamar.