This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 14, 2018 at 9:00 pm #2736684

marijoC

Tell us what you are trying to do? I am trying to translate a LayerSlider slide show and it's only allowing me to translate one slide in string translation. So the same text is showing in French on all three slides.

Is there any documentation that you are following? Yes, yours.

Is there a similar example that we can see?

What is the link to your site? hidden link

September 17, 2018 at 5:17 pm #2742081

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

Also, I checked your website and I don't see a slide in English that shows French strings. Can you please send me a screenshot of which slide you are seeing with the wrong language?

September 17, 2018 at 5:48 pm #2742122

marijoC

Hi Lauren, Here is the page that the slider that I need to translate is: hidden link

What I am seeing in String translation is as per the screenshot. IT only gives me 6 fields to change and then the result is what you see on the above page if you switch to french in the menu. So only the last slides text is being translated and then showing on all slides.

September 17, 2018 at 6:50 pm #2742314

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

September 18, 2018 at 12:51 pm #2745092

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for allowing access. I did a search in WPML -> String Translation for a few of the words in one of the slides. I found a page builder string with the slide content that showed as needing an update for the translation. Once I checked the box as complete and clicked save, the translation showed up on the frontend. So it looks like the slide content is wrapped in a page builder string. You can search for each string and then update the translation and click Save, and the rest of your strings should show the translations correctly.

Please let me know if you need any further assistance and I will be happy to help.

September 21, 2018 at 4:45 pm #2756024

marijoC

Hi there,
I have searched for the titles in 2 of the sliders and they are not coming up in string tranlation. I have attached a screenshot. What am I doing wrong?

September 21, 2018 at 5:15 pm #2756106

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Can you please tell me how you are adding the slider to your page here hidden link? I looked at the Cornerstone editor but I don't see the slider added there.

September 21, 2018 at 5:52 pm #2756275

marijoC

Sure. If you go to that page in cornerstone you will see a section called "Slider". Click on it and the slider section will change to a text section and the sidebar will look like the screenshot. CLick on 'Edit Text' under Content and you will see the shortcode: [layerslider id="1"]

September 24, 2018 at 5:45 pm #2761494

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for the additional information. I went into your slider and made a slight change in the text, and saved the change. Then I undid the change and saved again. Now, when I went to WPML -> String Translations and searched for the string, I saw that it showed the translation needed an update. I resaved the translation and now the correct string is showing on the frontend of the site.

Please let me know if you need any further assistance and I will be happy to help.

September 28, 2018 at 2:55 pm #2774270

marijoC

Hi there, I need some help with this site. What are my options? The actual homepage has now reverted a bunch of text back to English. See here: hidden link when you switch to french the lines of text under the heading: CARACTÉRISTIQUES DE COMPLIPAK
used to be french but now are in English, as well as the paragraph of text directly below that one. and then a but further down: “Did I take all of my medication at breakfast?”
Complipak is a helpful aid for patients facing self-administering challenges.

When I look at the strings they all are the correct French, so I am not sure what's going on. The other issue that I started this string is secondary as it's a hidden page at this point - but this new issue is serious as it's front facing. Is it possible to have a phone or online support call? I need to fully understand and rectify some of these issues fast.

September 28, 2018 at 3:11 pm #2774298

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

As the original issue is resolved may I kindly ask you please to open a new ticket for this question?
This will also help other users with similar problems find solutions when searching the forum as well as we avoid mixing lots of questions in one ticket.

Thank you for your understanding.

September 28, 2018 at 9:12 pm #2774882

marijoC

Hi there,
The original issue has not been solved, so I will continue this thread for it but will start another one for the other although the second issue happened since I have given support access to the site so that was why I wanted to keep it in the same thread.
Okay, so this page: hidden link I have moved the slider over to here: hidden link as that is where the end version of it will be. If you go to it and look at the slider and then click on the french, it's a completely different slider from a different plugin.

October 1, 2018 at 1:16 pm #2778251

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

If you deactivate WPML temporarily, does the correct slider appear?

If you go to WPML -> Settings and switch to manual translation, you should be able to manually change the shortcode to the correct slider. Please let me know if this resolves the issue.

October 1, 2018 at 1:54 pm #2778341

marijoC

Hi There,
Before I do either, is there any risk of losing the translation that has already been done?

October 1, 2018 at 1:58 pm #2778367

marijoC

Okay, deactivating plugins didn't work. I cleared cache afterward and still nothing. I'm so frustrated 🙁 Is there any way I can look at this on an online meeting forum? I have to get this resolved.