This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by wolfgangD-6 2 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 25, 2019 at 12:12 pm #4282873

wolfgangD-6

Dear WPML team

I translated the texts for LayerSlider WP with string translation. But still the original texts (EN) do appear on the website => hidden link

As a possible solution in your forum I found that the slider markup caching can be disabled:

https://wpml.org/forums/topic/the-german-translation-shows-the-english-layerslider-instead-of-german/

But I cannot do this because I don't have the option available under LayerSlider WP > Options > Advanced (maybe because I don't have the pro version).

I also would not like to deactivate the LayerSlider WP cache because the site is anyways already too slow and overloaded. I hope for a better solution.

Can you please help?

Thanks a lot, have a nice day,

Wolfgang

July 25, 2019 at 5:16 pm #4285349

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 26, 2019 at 9:45 pm #4291957

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I am jumping here to let you know I would need some extra hours to investigating your issue into details. I will be back as soon as I am ready with a detailed and accurate answer. Thank you for your continued patience and understanding, have a nice day.

July 26, 2019 at 10:21 pm #4291979

wolfgangD-6

Hi Marco

Thanks for the information, that's very kind to let me know. Thanks a lot for your time and effort already now.

Kind regards,

Wolfgang

July 29, 2019 at 5:25 pm #4302533

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Wolfgang,

Thank you for your patience while waiting for a solution. I took a detailed look in your website and created a sample slider 'WPML Test Slider' and placed it in a test page called 'WPML Test Page' you can see the results at:

English: hidden link
German: hidden link

Even your previously created slider german translation is working properly as you can notice at: hidden link.

So, in your case a cache issue may be interfering in your results. I recommend you to double check our instructions at: https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-using-layerslider-and-wpml/ and make sure to test your changes with any cache cleared, I recommend you to test it using another browser or using your browser incognito mode.

Please, let me know if you need any further instructions and assistance, have a nice day.

July 29, 2019 at 6:47 pm #4303129

wolfgangD-6

Dear Marcos

Wow, it really works with your slider, that's so fantastic!

Still it does not work with my slider, not even in incognito mode of the browser. But I won't give up and try later on this week again 🙂

I'll keep you updated, thanks again for your time and help.

Kind regards,

Wolfgang

July 29, 2019 at 7:02 pm #4303189

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In your migrated copy it works at: hidden link. so in your case if you didn't change any setting it should be a cache issue. I also recommend you to delete the current strings and try a new fresh translation for your slider strings. Have a nice day.

July 29, 2019 at 9:46 pm #4303673

wolfgangD-6

You are right, it really works! Seems like the issue has something to do with the strings. Can it be that every time the slide in LayerSlider WP is saved new strings are generated (even if the texts did not change)? So that first all strings must be deleted and then the plugin must be scanned for new strings which have to be translated again?

What if the text box is centered but the translated text has a different length? The text box will not be centered again 🙁 please see the attached picture. Any chance to fix this?

Thanks a lot again, kind regards

Wolfgang

July 30, 2019 at 1:35 pm #4308039

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Regarding your questions:

1 - "...Can it be that every time the slide in LayerSlider WP is saved new strings are generated (even if the texts did not change)?..."

In my tests the strings are added automatically, if you delete the LayerSlider string in your WordPress Dashboard > WPML > String Translations and you refresh the page the strings will be added again with no translations assigned to them.

2 - "...What if the text box is centered but the translated text has a different length?..."

It all depends on the alignment settings you set for your text layers in your LayerSlider slider settings. In this case you should make sure your text layer is centered aligned. You can see the results of this alignment here: hidden link. See attached screenshot.

Hope it helps, have a nice day.

July 30, 2019 at 7:56 pm #4310327

wolfgangD-6

Dear Marcos, yes, it's really some kind of caching issue and also the page where the slider appears must be newly updated, then everything works. Also the centering of the translated text in different lenghts works fine (sorry, this was definitely a handling fault from my side).

Thank you so much for your time and effort, you made my day!

Kind regards,

Wolfgang