This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Raja Mohammed 2 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 30, 2019 at 3:23 pm #4309153

vinceB-2

I am trying to translate a page from English to French. I want the French version to have the exact same layout as the English version of the page.

Link to a page where the issue can be seen: hidden link

I expected to see: that the French version has the exact same three columns, the hover effect and everything else just like the English version.

Instead, I got: the French version with no visible layout. Everything is just centered in one single column.

It seems like no layout settings have been transferred to the French page.

I also have the issue that every time I open a page in order to edit it, I get the following message: "You are about to change the language of Welcome TEST - copy.
Please make sure that you've saved all the changes. We will have to reload the page.
Do you want to continue?" I can only cancel this message. Could this mean that my theme (hidden link) doesn't support WPML?

July 31, 2019 at 4:31 am #4311437

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

The popup appears when you change the language of a post...
when you change the language, the editor has to be reloaded so you lose any changes you made.

It seems you are using Siteorigin builder to create the pages, WPML works differently with Siteorigin. I would recommend you please refer to the detailed documentation on how to translate pages created using Siteorigin
https://wpml.org/documentation/plugins-compatibility/using-wpml-siteorigin/

I hope this helps you better.

Let me know if you need further assistance.

Kind regards
Raja

July 31, 2019 at 1:36 pm #4314789

vinceB-2

Hi,

thank you so much for your help. I followed the steps described in the documentation. However, when I want to edit the page it still gives me the message ("you are about to change ..."). And when editing the french duplicate of the page, the SiteOrigin Builder is not active anymore and my layout is gone.

July 31, 2019 at 1:40 pm #4314833

vinceB-2

I also don't have the pencil to edit the translation. Instead I have to go back to "pages" and click on the french pages button in order to find and edit the french version.

August 1, 2019 at 3:52 am #4318561

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please share temporary access to your site, I can have a closer look into the issue. I have enabled private fields for you to securely share the details.

Regards
Raja

August 2, 2019 at 6:40 am #4327227

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

This seems like a WPML conflict with any of the plugins in your site, As i can see a strange behavior happening when I click to translate the pages.

Please perform basic troubleshooting steps

- Secure a backup of your site and database

- Disable all non-wpml plugins except WooCommerce and site origin page builder, Check if the issue can be reproduced

- If the issue disappears enable the plugin one by one and check if the issue can be reproduced, this will help in figuring out the conflicting plugin.

Please share the results with me.

Kind regards
Raja

The topic ‘[Closed] Layout changes when switching languages’ is closed to new replies.