This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to translate/update the pages using siteorigin page builder

Solution: The steps to translate the page with site origin page builder is:

  1. Create a page in a default language
  2. Duplicate the page in the secondary language
  3. Once duplicated open the page in secondary language and set it as independent translation
  4. Make the translations

How to update the pages/posts layouts contents

  1. Update the page's posts in the default language
  2. Open the page in secondary languages and do the same changes there too.

Relevant Documentation: https://wpml.org/documentation/plugins-compatibility/using-wpml-siteorigin/

Tagged: 

This topic contains 26 replies, has 3 voices.

Last updated by vinceB-2 1 month, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 29, 2019 at 3:11 pm

vinceB-2

I am trying to translate a page from English to French. I want the French version to have the exact same layout as the English version of the page.

Link to a page where the issue can be seen: hidden link

I expected to see: that the French version has the exact same three columns, the hover effect and everything else just like the English version.

Instead, I got: the French version with no visible layout. Everything is just centered in one single column.

It seems like no layout settings have been transferred to the French page.

July 29, 2019 at 3:53 pm
July 29, 2019 at 4:02 pm #4301665

vinceB-2

My backup has now finished.

July 30, 2019 at 11:34 pm #4310741

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for the credentials. I checked the site and I don't understand why you are getting that message even doing anything to the page. It might be caused by some 3rd party plugin, but if your site is live, it won't be possible to perform a compatibility check.

I'd like to take a copy for further testing. Let me know if this is okay and I'll send you instructions.

July 31, 2019 at 1:42 pm #4314859

vinceB-2

Hi,

thank you for your help.

Will anything happen to the original website when you copy and work on it? If not, I'm ok with doing that.

August 1, 2019 at 7:27 am #4319263

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

no, we're working on a copy exactly to avoid any issue with your site.

I'll send you instruction shortly.

August 1, 2019 at 7:31 am
August 1, 2019 at 2:09 pm #4322537

vinceB-2

The Migration is now complete. Thank you.

August 2, 2019 at 9:24 am #4328445

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I checked the site and I found that you get the message "You are about to change the language of Welcome TEST.
Please make sure that you've saved all the changes. We will have to reload the page.

Do you want to continue?"
happens when the plugin Infographic Maker iList is active along with WPML and Page Builder by Site Origin.
I'm not sure this is 100% related to the initial issue but for sure you shouldn't get this message.

Can you please go here: hidden link
and install your theme + Infographic Maker iList and see if you can reproduce the issue?
WPML is already installed, you just need to configure it.

August 6, 2019 at 1:46 pm #4347999

vinceB-2

Hi,

thank you so much. By deleting the plugin Infographic Maker iList the message does not appear anymore. Now the only problem I have is that when I edit the french version of the pagem the SiteOrigin Page Builder doesn't work. I can only edit with the original WordPress buider and my layout is gone. Could you help me with this as well?

Thank you!

August 6, 2019 at 1:52 pm #4348011

vinceB-2

I installed the plugin and my theme on the example website and the message doesn't come up. Even when also installing the SiteOrigin page builder the message doesn't come up. I think the reason might be that the WPML widget is not set up 100% and the website is not registered.

August 7, 2019 at 9:01 am #4352997

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I noticed the WPML editor is disabled in your site, that's why you can only edit with the regular WordPress editor. I enabled it for you and it should be fine now.

I tried translating a couple of pages on my site copy and the layout seems fine to me. Can you try it too and see what you get?

August 7, 2019 at 1:05 pm #4355285

vinceB-2

Good Morning,

thank you for your help again. On this page it says to turn off the WPML editor when using SiteOrigin page builder which is why I turned it off. Should I turn it back on for sure?

Thank you!

August 7, 2019 at 1:24 pm #4355353

vinceB-2

Hi again,

the layout of the french pages is still not there. You can see the layout change when switching from English to French on the Welcome TEST page.

August 8, 2019 at 4:05 pm #4364635

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

when you say "On this page it says to turn off the WPML editor when using SiteOrigin page builder which is why I turned it off." which page are you referring to?

Could you try creating a new page (from scratch, not cloning an existing one) and see if translating it the problem still exists?