This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
September 24, 2018 at 12:15 pm

maijaK-2

I am trying to:

I have updated the mobile version logo and mobile & desktop version pictures on the English page but it won't be updated on my language version pages.

Link to a page where the issue can be seen:
This has the right pictures: hidden link
but here in the Finnish & Swedish version you have the old pictures: hidden link

Also check out the logo on mobile versions languages pages. On English page is correct.

I expected to see: hidden link

Instead, I got: old version of the page: hidden link

September 25, 2018 at 3:58 pm #2764643

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @maijak-2, welcome to the WPML support Forum!

Are you using the Manual Editor or the Classic Editor to translate the pages? You can check it on WPML > Settings > How to translate posts and pages.

Manual Editor
If you are using the manual editor, each page/translation is independent. In this way you must also modify the translation and save:
- Go to the edit screen of the page (default language)
- Change the language using the Language Switcher at the top admin bar
- Edit the content and save

Classic Editor
If you are using the classic editor, the modifications on the original language will be automatically applied to translation, but you still need to update the translation to apply the update:
- Go to the edit screen of the page (default language)
- Modify the content and save
- Go to the translation editor (edit the translation)
- Check all "Translation is complete" fields and save

I also checked the settings of your server through the debug log and saw that some items need attention:
Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb only.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

If you need more help just let me know.

All the best,
Diego

September 26, 2018 at 12:49 pm #2767324

maijaK-2

Hello Diego,

Thank you for your reply.

I am using the manual editor ("Create translations manually").

The problem I'm having is about the images (they won't update on the other language pages) so I cannot edit image content on the translator as you advised.

About the memory. Is this php.ini file something that is on the FTP? Can I change the memory somewhere in the WordPress platform instead of using the FTP?

Looking forward to hearing from you as soon as possible.

Anna

September 26, 2018 at 7:55 pm #2768556

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

This is odd, the classic editor is set, but when I try to edit a translation it opens the translation editor screen (see screenshot).

Please try the following:
- Go to the edit screen of the page (default language)
- do a small modification on the content and save
- Change the language using the Language Switcher at the top admin bar
- If it display a warning, click on "Edit Anyway"
- Edit the images and some test content and save.

Please check if the changes are applied to the page. If not, please try the following:
- Duplicate the original page using a plugin like this: https://wordpress.org/plugins/duplicate-page/
- Create a new translation to the page, modify some content (images and texts) and save
- Check if the same issue occurs on this new page

Regarding the server settings issue, please check with the support of your hosting server. They can guide you better in this case because each server has a specific configuration.

Please let me know if it worked for you.

Kind regards,
Diego