This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 9.29 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:
Same layout between original and product pages. Including the product variations. in WP Bakery page builder

Solution:
The theme is missing some custom field tranlsation rules. Add the below codes in WPML> Settings> Custom customisaiton xml

<wpml-config>
    <custom-fields>
        <custom-field action="copy" label="Product Design">_basel_product_design</custom-field>
        <custom-field action="copy" label="Product layout">_basel_main_layout</custom-field>
    </custom-fields>
</wpml-config>

This topic contains 6 replies, has 2 voices.

Last updated by alinam-2 8 months, 2 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
January 2, 2019 at 6:25 am

alinam-2

I am trying to: Have same layout between original and product pages. Including the product variations.

Link to a page where the issue can be seen:
hidden link
hidden link

I expected to see:
Same layout between pages

Instead, I got:
The name of the attributes are displayed in both versions
The name of the variations are not displayed in translated version but are in original version

This feature of the product page layout is a parameter for each product.
On product page, you choose "Product page design"
With choice of "inherit", the name of variation is not displayed
With choice of "default", it is displayed, it's what is chosen for me, so, the names of variations should be displayed

Waiting for your feedback
Kind regards

January 2, 2019 at 7:34 am #3048032

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Welcome to our forum, I will be handling your ticket,

It seems like product custom fields don't have appropriate WPML rules and hence the settings are skipped during translation. kindly add the below XML code in "WPML > Settings > Custom XML configuration" save and update the translation and check whether you are able to see the layout same as the default language product.


<wpml-config>
    <custom-fields>
        <custom-field action="copy" label="Product Design">_basel_product_design</custom-field>
        <custom-field action="copy" label="Product layout">_basel_main_layout</custom-field>
    </custom-fields>
</wpml-config>

Please let me know if this helps, I will be happy to help you in case you need further assistance.

Best regards,
Raja

January 2, 2019 at 8:04 am #3048060

alinam-2

Hello Raja,
Thank you for your quick answer.
I think I did what you said. See attached.
If i create a new translation, it's OK, I mean I see the translation of the variation label.
For already translated products, no change. So, what shall I do of them?
Kind regards

January 2, 2019 at 9:46 am #3048399

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Please make some minor changes in the product default language and update. You will see a refresh icon in place of pencil icon in the translations section, Click on the refresh icon it will take you to the translation page, complete the translation and save. This will apply the missing fields for the already translated content.

I hope this helps you solve your issue.

Best regards,
Raja

January 6, 2019 at 6:47 am #3060080

alinam-2

Hello
OK, it works, but in terms of productivity, it's very bad .... if you want 200 items, open, wait loading, change, save .... it takes hours !
Kind regards

January 7, 2019 at 12:40 pm #3062663

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I can understand your situation.

However, the configuration for the custom meta is missing in the theme, if it was already provided by the theme then this process is not needed at all. Any new configuration added after the translation is done requires the original content to be updated, Since the translations take reference from the configuration rules and the content, If the rules are missing the translations will skip the fields and hence we suggest you update the original content to inform the translation regarding the fields to be translated.

I hope this clarifies the process, Let me know if you need any further assistance.

Best regards,
Raja

January 7, 2019 at 1:01 pm #3062713

alinam-2

My issue is resolved now. Thank you!