This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 4 voices.

Last updated by srdjan 1 year, 7 months ago.

Assigned support staff: srdjan.

Author Posts
April 12, 2017 at 4:15 pm #1253138


I am trying to:
Translate the quiz questions in my Learndash based LMS. They recommended your plugin and mentioned they are working with you to test complete compatibility. So far it seems to be working fine, I just can not see where to add the actual quiz questions to the list of items available for manual translation. Any ideas?

April 13, 2017 at 10:42 am #1253658


Hello @scottz-2,

First of all, please make sure that all your plugins, the theme, and WordPress itself are up to date. If not, please update them. Remember to make a full backup (files and the database) before updating.

If I understood you correctly, you add the quiz questions as a plugin option, am I correct?. If so, you need to create a language configuration file for Learndash.

You can read more about language configuration files at

Then, when question fields are properly registered, they should be available for translation in WPML->String Translation.

Regarding the Learndash compatibility, we worked on it but we are still waiting for their response that is needed during the process.

April 17, 2017 at 4:25 pm #1255400


I still cant get this to function. It also seems to be affecting my slide pages. Learndash is marking them all as "Done", rather than presenting the user with a next slide button? It may be related to the url or the way the Spanish versions are organized. Is it better to duplicate the slides per language or just translate? Translating through the translation management tool isn't functioning. Any help would be greatly appreciated.

April 18, 2017 at 1:47 pm #1256106


Hello @scottz-2,

It would be really helpful for me if I can see your page backend. So if it's okay with you, I would like to ask you for credentials to your website and FTP. It will help me debug the issue and find the solution. You will find the fields for WordPress and FTP access below the comment area when you log in to leave your next reply.

Please also write the steps I should follow to replicate the issue.

April 19, 2017 at 1:58 pm #1257166


Hello @scottz-2,

Thank you for the credentials. Do not lose hope yet. I'll check your website and get back to you.

April 19, 2017 at 2:42 pm #1257219


Hello @scottz-2,

I checked your website and I noticed that you didn't have your slides translated yet. The one that you started translating was marked as 25% completed. In this case, before the post (in this case: the slide) is not marked as 100% completed, it won't be treated as an existing translation.
I marked it as 100% completed, adding "ES" to the empty fields. It seems that everything works correctly now.

You need to translate not only your Slides but Courses, Modules, etc., as well. Then, the pagination will work correctly as well because you will have correct relationships between courses, modules and slides set.

You can check it on your website now. Do not worry that your clients will see any changes because I marked Spanish as hidden. You can change this option in WPML->Languages->Hide language.

April 19, 2017 at 2:48 pm #1257232


Ok. That makes sense. I will make sure all is 100% translated then test. I was translating then testing as I went. So that could explain why the slides weren't organized properly.

Were my other settings correct? As far as URLS etc?

Thanks for your help.


April 20, 2017 at 3:08 pm #1258227


Hello @scottz-2,

Most of the settings look fine. Most of your custom posts are set to be translatable, as well as taxonomies. You can always check the settings in WPML->Translation Management->Multilingual Content Setup->Custom posts, and adjust them according to your needs.

However, your custom taxonomies are not set to be translatable. Possibly you want to change it. You can do it in WPML->Translation Management->Multilingual Content Setup->Custom taxonomies.

I would also recommend you to use a different language URL format, i.e. "Different languages in directories". You can set it in WPML->Languages->Language URL format. Sometimes the "Language name added as a parameter" option may not be compatible with the theme or one of the installed plugins.
When you change the language URL format, remember to go to Settings->Permalink and re-save the setting. This will refresh the permalink settings and clear any cached data.

Additionally, please remember that the Enfold theme has separate settings for each language. If you see differences between the way the content looks on the frontend in different languages, it may be because you changed the theme option for one of the languages only.

May 9, 2017 at 5:45 pm #1272056

Danielle Cranmer


I also am trying to figure out how to translate LearnDash quiz questions, but I am new to WordPress so I didn't quite follow your reply #1253658 above, @joanna. @scottz-2, were you able to successfully implement that method for translating the quiz questions?

thanks for any guidance you can offer!

August 9, 2017 at 7:39 pm #1338823


So I created a duplicate version. Its is mostly translated, but I can not get some content into the que, or to even show up for translation. Quiz pages for example. Can you let me know what I am doing incorrectly. This is definitely the way to go, just need to get it to 100%. I can provide new credentials.

hidden link

August 10, 2017 at 8:01 pm #1339701


Hello @scottz-2,

Could you please share the steps you follow to translate the Quiz pages? It will help me replicate the issue and spot possible setting issues.
I'm setting the next reply to be private in case you want to share different credentials that before.

@daniellec-3, I strongly recommend you to open a new ticket with your questions. Since your installation is different from scottz-2's one, it's possible that we may need to find solutions for different issues in your case. This way we will be able to fully focus on your specific case.

August 16, 2017 at 4:58 pm #1344679


Hello @scottz-2,

I'm sorry you had to wait so long for the answer. I read your reply but I didn't quite get what the question is. Could you please elaborate more on the issue? Steps to replicate the issue are highly appreciated, as well as screenshots with the issue being visible.

August 16, 2017 at 5:50 pm #1344706


No problem.

When going to the beta site: hidden link
Even on the login page, using the language switcher flag in the upper right does not function. I am assuming because the content has not been translated. I guess my question is, how do I make sure all items in need of translation are available when sending to an internal translator? Do the pages need manual translation using the +? I am also seeing items on the course content page - showing twice. In English and Spanish. You can dig around and modify whatever you would like. Its just a test site. Im just not sure what I am doing incorrectly.

August 18, 2017 at 3:33 pm #1346195


Hello @scottz-2,

Regarding the pages, you can translate them manually yourself by clicking the "+" sign. You can also send them to translation in WPML->Translation Management.
As you already noticed, the language switcher on the front end won't work unless you have at least two language versions of the particular page.

You may read more about different ways of translating your content at

Additional documentation:

Regarding the course content being listed in both languages, our Compatibility Team is currently testing the compatibility between WPML and LearnDash LMS. They already spotted the issue you mentioned and they are looking for the solution. I'll let you know when I have any feedback from the Compatibility Team.

October 8, 2018 at 12:32 pm #2795978


Hello Scott,
I would like to inform you that issues with LearnDash are resolved.

Can you please re-check and let us know?

Thank you.