This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 32 replies, has 4 voices.

Last updated by Andrés 1 year, 11 months ago.

Assigned support staff: Andrés.

Author Posts
May 30, 2018 at 9:50 am #2249982

alexG-29

I am trying to:
- I have imported both English and French pages (already fully translated)
- I edited french language pages to "French" with "Language of this page"
- Then "connect with translations"
- Then selected the english page
- Finally assign

Link to a page where the issue can be seen:
In Dashboard ...

I expected to see:
To be redirected to English page when I select "edit English translation"
Or to have proper English content from English page in "Page Translation" that I could save & close

Instead, I got:
All pages 0% translated with French text in English input when I select "edit English translation"
See attached : Page translation.png

And "Warning: You are trying to edit a translation that is currently in the process of being added using WPML." when I clic on linked English page
See attached : Home.png

I need to resign in "Page Translation" and cancel translation job in "Translation manager" to be able to come back to normal page editing
See attached : Accueil-French-page-for-Home.png

Can you explain me what am I doing wrong here ?

Kind regards,
Alex

May 31, 2018 at 5:49 pm #2257943

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

In order to translate the page in the native WordPress editor, please go to WPML -> Translation Management -> Multilingual Content Setup. In the first section, change the settings to translate manually instead of using the Translation Editor. Now when you edit the English page you should see the native WordPress page editor.

Please let me know if you need any further assistance and I will be happy to help.

June 4, 2018 at 10:07 am #2267895

alexG-29

Thank you for your answer, this workaround solved the first part of the issue during import of existing data and linking already translated pages.

Now the issue is re-happening after linking existing pages :
After reactivating the translation editor, with the mode "Don't include already translated terms in the translation editor", again translation editor is showing me untranslated strings from the pages that were already linked before !!

Any idea why and what to do ?

Thanks, Alex

June 4, 2018 at 2:35 pm #2269675

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'm not sure I understand the 2nd part of the issue correctly. Is the correctly translated content showing? If so, you can just mark the translation as 100% complete.

Maybe a screenshot of what is happening will help me better understand. Also, you may try going to WPML -> packages and delete the package for the page, but please keep in mind that this may delete your translations so you would want to make a full backup of the site first, and test on a small page or a test page if possible.

June 4, 2018 at 5:31 pm #2271094

alexG-29

Both pages are in their respective languages in native wordpress editor.

Then I switch back to Translation editor for coming pages to be translated : WPML -> Translation Management -> Multilingual Content Setup.

The issue is when I open any page linked previously, and select "edit with translation editor", the content is not translated as you can see screen shot "Page Translation.png" (linked in 1st post).

Only the name is in respective languages, all the rest is either all in English, if I open English page or all in French if I open French page ... (unexpected)

If I open the previously linked pages and select "edit anyway" (wordpress native) then the content is in respective languages (like expected)

Tell me if you didn't get my point

June 4, 2018 at 5:57 pm #2271115

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

June 4, 2018 at 8:08 pm #2271688

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for providing login information. I see that you are using the Elementor page builder. Elementor recently changed the way that their content is translated and it has not been working with our translation editor. Our developers are working to find a resolution to work with the new Elementor translation methods. I'm not sure if this is what is causing the issue for you, but it very well could me. For now we are recommending to use the native WordPress editor and edit your content directly in the page.

One other thing you can try is going to WPML -> Packages and delete the package (for example, since this page is translated you can try deleting Page Builder Page 1134). Then update the page in the original language, and then try to edit the translated page. Please keep in mind this might delete the translation.

If the translation still does not display correctly in the translation editor after this, you can try the following (Please be sure to make a full backup of your site and database).

Then, go to WPML -> Support -> Troubleshooting.

Look for 'Clean up' and click the following:
- Synchronize posts taxonomies
- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix Terms count
- Fix post assignment for translations

If neither of these issues resolve the issue, then I imagine it is due to the recent changes in Elementor translation changes. Let me know and I can escalate to our 2nd tier if needed.

June 5, 2018 at 5:46 am #2272491

alexG-29

Thanks for information about elementor translation management change and I confirmed with my client he is extensively using elementor - Never use wordpress editor.

As usual : 1. Arunachal-Arts-Translation.png is what I get from translation editor

2. I tried deletion of package (here 947), I actually deleted them all.

3. After deletion I get "Arunachal-page-translation-after-package-deletion.png", I then check "Translation Complete" for 100% translation, Save and close.

4. I actually get pages in their respective languages

5. I tried then to update the content of English (original page) by adding "trial text" at the end of the content with Elementor

6. I get "Arunachal-arts-translation-after-original-page-modification.png" where I need to translate the full text again ...

I tried Troubleshooting, Clean up, all the steps above without any change

Note : my engaging deadline with the client is to complete migration from his multi-site website to WPML translation by june 10th. Do you think issue with Elementor could be solved within 2-3 days ?
In the negative, could you recommend me an easy to use and visual Page Builder which would be 100% compatible with WPML so I could ask my client to consider switching ?

Kind regards,
Alex

June 5, 2018 at 2:25 pm #2275808

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

WP Bakery page builder is compatible with WPML. However, if you disable the translation editor and use manual translation, everything should work correct for your client to continue translating. It seems the only problem is the content coming into the translation editor. So, if you change that, your client would just use Elementor on both the original language page and also on the translated page. Would that work for your client?

June 5, 2018 at 5:36 pm #2276718

alexG-29

I understand this part but I convinced the client to migrate from multi-site based multi-lingual website to WPML - for the ease of translation management - as it is presented here :
https://wpml.org/documentation/plugins-compatibility/elementor/

Sadly I don't want to recommend wp bakery from elementor, especially for their lock-in strategy ...

Do you have any estimation from dev team about required time to fix the compatibility issue ?

June 6, 2018 at 9:06 am #2278919

alexG-29

To meet client deadline I will deactivate “translation manager” and link the respective elementor versions for translated pages as suggested.

And put the website in production by end of the week.

Can you confirm that when the issue will be fixed, I will be able to reactivate again “translation manager” and use it for further modification of these pages ?

The same way we can see here : https://wpml.org/documentation/plugins-compatibility/elementor

Thank you

June 6, 2018 at 2:02 pm #2284896

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Our goal is to get the translation editor working with Elementor again. The problem is that they released their own version of translating content and we just recently found out about it, so now our developers are doing everything we can but we will need the assistance of Elementor. I can guarantee that we will look into every issue.

I'd like to further troubleshoot this locally so as not to disrupt your live site. Please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

June 7, 2018 at 1:58 pm #2396586

alexG-29

After update same old issue here ...

That's the process I follow :
1. Import English (Original) pages with import tool as "english"
2. Import French (already translated) pages with import tool as "french"
3. Pages => French => "Page 1 in French" => Connect with translations => "Page 1 in English" => ok => uncheck "Make French original"

And still Elementor strings are not translated in the classic WPML translation manager ...

Only Name and slug appear in French

June 7, 2018 at 8:25 pm #2397860

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @alexg-29, Lauren is not working today, I'll help you for now.

Unfortunately we are experiencing compatibility issues with the new versions of Elementor, which our team is working hard to solve, but we still need the assistance of Elementor.

According to our documentation, the last compatible version tested was 1.7.1: https://wpml.org/plugin/elementor/

You can use a plugin like this to rollback the version: https://wordpress.org/plugins/wp-rollback/

IMPORTANT: Please backup your website and database before. You need to be aware
that the modification of the version may causes some errors.

Regards,
Diego

June 9, 2018 at 11:07 pm #2403001

alexG-29

Successfully rolled back elementor to 1.7.1 and same issue appears ...

Can you confirm that I can link pages using WPML manual mode in the wait of translation editor working with elementor ?

And that when the compatibility issue will be solved, I will be able to reactivate Translation editor and use it as expected with manually linked pages of previous step ?

Is there any update from your dev team ? When Elementor support claims "it's solved"