Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bruno Kos 11 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
March 5, 2019 at 1:00 pm #3273956

hooiC

Tell us what you are trying to do? I was on the German site ( development site) and I clicked on MEHR LESEN link(1.screenshot). This took me to ‘amIovulating’ page . It took me to the German translated content but look at the header of the 2nd screenshot. It has myLotus.com link(not de.mylotus.com…) ! Its not right as the menu on the 2nd screenshot is in English! how can get to the correct German translated content within its own German site? we use Avada fusion

On the source page for the first screenshot: the link to the #amiovulating is as follows:

href=hidden link target=_blank rel=noopener>MEHR LESEN</a></div></div><div

Please do not make any changes to our development website as its our master copy. please advise us how to fix this issue. i also attach the text block where the english text -amiovulating id is located -see screeshot no 3.
Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site? webdev.mylotus.com

March 5, 2019 at 3:10 pm #3274780

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

From what I see, it takes me to hidden link, however, it redirects to wrong domain after that - hidden link that is.

There is one thing I am noticing:
hidden link

So all the links on dev are "dedev" and not "de". If you try the link from above, but change dedev to de (like hidden link) it will also take you to:
hidden link

Or in other words, if you open:
hidden link

It will take you there as well.

So possibly you don't have correct links on your development site (could be due to site migration). All these should be "dedev" and not "de", so you could try replacing them all on dev site. I assume this is for other domains as well.

You could try with plugin such as:
https://wordpress.org/plugins/better-search-replace/

Please make a full backup of your site before trying this.

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

March 5, 2019 at 3:24 pm #3274829

hooiC

Hi Bruno, thank you for getting back to us .Can the url be changed manually or change some settings in the files? I am not keen in using plugin at the moment as we have slow performance issue at the moment and we are trying not to put another plugin..

March 5, 2019 at 4:04 pm #3275049

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

You have 3 options at least:
- try bulk with any database search/replace plugin
- manually on pages/posts, etc.
- through more advanced approaches like wp-cli

It is stored within database alone, not within plugin/theme files or elsewhere.

Regards,
Bruno Kos

March 5, 2019 at 5:14 pm #3275481

hooiC

Hi Bruno thank you for the summary. i am not able to see the url in the code block to change from de to dedev in the strings or in the translation editor. So, what I did was in ADMIN, i go to the HOME page, change the language switcher from English to German. then go to the code block , open it up and change the URL. but before this, there was a warning i am editing in wp editor and it says originally edited in wpml editor. i ignore this message. would this cause a problem? also, how can i get the script in the code block(Avada Fusion) to appear in the translation editor?

March 6, 2019 at 8:23 am #3277369

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

When using "Edit anyway", it should not interfere with existing translation, however, always make sure to backup your work before switching editors.

As for the code block, can you try adding this into WPML -> Settings -> Custom XML configuration, update the page in original language and try in CTE then?

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag encoding="base64" encoding-condition="option:avada_disable_encoding=1">fusion_code</tag>
        </shortcode>
    </shortcodes>
</wpml-config>

I am not sure if this works, though, due to base64 encoding:
https://wpml.org/forums/topic/wpml-avada-theme-translation-editor-bug/#post-1327904

Regards,
Bruno Kos