This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Bigul 1 month, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
August 14, 2019 at 10:40 am

Peter

When selecting a link (hidden link) it redirects it to hidden link. When I disable WPML the link works. I already went through all possible solutions including deactivating plugins and only when WPML is enabled, this problem occurs.

the site is protected with this access:
hidden link
(how can I make a private support ticket?!)

August 14, 2019 at 7:18 pm #4397177

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

The site authentication credentials are not working. So I am not able to visit the site. Please check.

Please deactivate WooCommerce Multilingual for a moment(when all other WPML plugins are activated) and check the issue is existing or not. Does it happen after upgrading to the latest version of WooCommerce?

Please note, the links and credentials you have shared will not be visible for other forum users. It will be hidden. Only you and forum moderators can access it.

--
Thanks!

Bigul

August 19, 2019 at 10:24 am
August 19, 2019 at 6:16 pm #4418273

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can reproduce the issue on your site now. But one doubt. How you are changing the URL of *My Account* page to hidden link or hidden link for a better understanding.

--
Thanks!

Bigul

August 20, 2019 at 7:17 am #4421009

Peter

I am not sure what the question means, but if you are asking why there is a redirection to the individual member's page, this is the normal behaviour from buddypress and is typically set in it's property page: hidden link. Every submenu is than called with that member's link plus the corresponding category (wall, info, shop etc.).

The thing here is, that the link does NOT work, when WPML is activated.
If you deactivate WPML, the link DOES work (i.e. hidden link

This leads me to the conclusion that the originator of that behaviour is WPML, porbably because of some incorrect redirection.

August 20, 2019 at 6:00 pm #4425801

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

August 21, 2019 at 9:30 am #4429417

Peter

Sure, whatever you need to solve this issue! Do you need anything from my side?

August 21, 2019 at 6:28 pm #4434643

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for your permission. I made a Duplicator copy of your site now. Will debug it further and get back to you soon. Please wait.

--
Thanks!

Bigul

August 23, 2019 at 12:18 pm #4447009

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

It looks like the issue is happening because of a compatibility conflicts with WPML and Youzer plugin. The problem is existing after the initial debugging steps. So as a part of our escalation procedures, I have tried to reproduce the issue in a fresh installation. But not able to reproduce it exactly in a fresh installation. May I will be missing some settings.

So I have a request. Please visit the following URL and check it possible to replicate the issue or not. It is a test site in our Sandbox server.

hidden link

This action will help us a lot and we can forward the test site for debugging to our developers easily. Please check and let me know your feedback.

--
Thanks!

Bigul

August 27, 2019 at 8:45 am #4463889

Peter

I activated Woocommerce support in youzer. The shop link in an users profile will also not work in your demo (see image)

August 28, 2019 at 7:26 am #4471563

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am escalating the ticket to our compatibility team for further debugging. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

August 28, 2019 at 12:15 pm #4474187

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We are getting the expected result on the sandbox site and local after adding the following code in functions.php of the theme. Please try it after a site backup and let me know your feedback.

add_filter( 'parse_query', 'youzer_wpml_fix_redirection' , 5 );

function youzer_wpml_fix_redirection ($q) {
	if ( bp_current_component() == 'shop') {
	    if ( isset( bp_core_get_directory_pages()->members->id ) ) {
		$q->set( 'page_id', bp_core_get_directory_pages()->members->id );
	    }
	}
}

Please check the following link and attached image for more details.

hidden link

--
Thanks!

Bigul

August 30, 2019 at 8:37 am #4485293

Peter

Could you please be more precise where to exactly put that code, because no matter where in the theme's functions.php I paste it, I get this error "Die Website weist technische Schwierigkeiten auf." which means "The site is experiencing technical difficulties".

August 30, 2019 at 8:40 am #4485327

Peter

Ah.. ok. The mistake was that I copied the code from the email I received from you an it looks like the code below (maybe you should be aware of this for future support on other issues). Otherwise it worked well. This is obviously a temporary solution, my question is who will fix this, is it on your side or the theme developer?

Thank you!

add_filter( 'parse_query', 'youzer_wpml_fix_redirection' , 5 );

function youzer_wpml_fix_redirection ($q) {

if ( bp_current_component() == 'shop') {

if ( isset( bp_core_get_directory_pages()->members->id ) ) {

$q->set( 'page_id', bp_core_get_directory_pages()->members->id );

}

}

}

August 30, 2019 at 12:55 pm #4487295

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. This has to be fixed in the Youzer plugin. It will be great if you can request them to apply for our Compatibility program. So we can fix these types of problems.

Please check the following link for more details.

https://wpml.org/documentation/theme-compatibility/go-global-program/

--
Thanks!

Bigul