This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
October 16, 2018 at 9:58 am #2820441

harrisD

I have this issue/question

I have set media translation to an image.
I have a link to this image to open full size
the question is: in the other language should open the greek version of this image?
You can check: hidden link
is the banner on top of logo slider.

If i switch to greek version image banner changes to greek version, but not the link to the big image.

October 17, 2018 at 5:17 pm #2825471

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Regarding your question, please, let us know how the page content is built. Are you using a page builder? If so, maybe you have to adjust the source of the link in your translated page to point to a greek version of the banner instead. In any case, please give us more details on how your page is setup. Thank you for your collaboration, have a nice day.

October 17, 2018 at 5:31 pm #2825495

harrisD

With WP bakery.
I do not have anywhere the option to change the link in the translated page.
As i said, in hidden link there is a banner just above the clients sliders.

Here, if you change language, image swaps. But link to the "big image, does not, even i set it to the media translation.
By the way, in the media translation, when i change the image for the other language, ask me for an image from my local computer. Not from images already uploaded. And after uploading this image, it is not visible in media. Is it normal?

October 17, 2018 at 8:03 pm #2825831

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would suggest you to manually edit your greek page in order to update any possible reference to the big image, so this way you could find the greek version of your image and update this url. I need to know if you are using a specific WPBakery block to insert this image or if you are using just a regular block with some html content. As regarding the uploaded image it should appear in the WPML Media Translation screen for its respective language. In summary, here are the detailed steps you should take:

0 - Upload the big greek image using the regular WordPress Dashboard > Media upload feature.

1 - In your WordPress Dashboard > Pages click to edit the page where you have placed your banner.

2 - Switch to the Greek language.

3 - Find the block where you have your image banner and look for any hard coded url for a full size image you might have.

4 - Edit your block to point to the greek version of your image you uploaded in the step 0.

If any of these steps don't work for you, please, make sure to provide us with some WordPress Dashboard details so we can have a further look. This info is not publicly visible, instead only support staff and you have access to it. These details are used for support purpose only.

Thank you for your collaboration. Have a nice day.

October 28, 2018 at 5:07 pm #2856325

harrisD

The link to the big image is through wpbakery as you can see in screen01.
I do not have the option to change this link in translated greek version (screen02).
And trying to do it with media translation, i can;t select an image from uploaded images. But even if i upload it again form my local computer, still no image swaps. See screen03.

October 29, 2018 at 7:13 pm #2859282

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case an additional investigation is needed, here I would need some WordPress Dashboard access, for that, please consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 30, 2018 at 12:33 pm #2861624

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I took a closer look in your WordPress Dashboard and fixed your issue, here are the steps I've followed:

1 - In your homepage I changed your website to the greek language.

2 - Then I clicked to edit your greek homepage version using the WPBakery in the backend mode.

3 - I found the 'Single image' block and then I updated the single image link to a greek version of the big image 'AfisaExoGR-3.jpg' (see attached images for reference).

Please, let me know if you need any additional clarifications. Have a nice day.

October 30, 2018 at 1:24 pm #2861916

harrisD

yes, problem solved, but i'm not sure if i get it right. Especially step 2.
You ignored the popup message (see attached screen).
Because i did not even try to hit the "edit anyway" button..... It makes me nervous....

If i get it right, from back end you can filter greek pages and select-edit the home page from there.

October 30, 2018 at 2:22 pm #2862190

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. You can get rid of this popup message if you choose to use the default WordPress editor for your translations, you are able to change these settings at your WordPress Dashboard > WPML > Settings > How to translate posts and pages here you can choose the 'Create translations manually' option.

In any case if you keep your settings as it is, you can click the Edit anyway button and go ahead editing the page content for your translations using the default WordPress Editor, instead the the WPML Translation Editor. Hope it clarifies, have a nice day.

October 30, 2018 at 3:35 pm #2862534

harrisD

That's nice. I always (in most cases anyway) wanted to edit in the default WordPress editor, but i was afraid to do so. So, actually WPML makes a duplicate of the page and it doesn't matter which way you choose to edit?

October 30, 2018 at 5:10 pm #2862966

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. No matter which editor you choose to translate your pages be it the WordPress Default editor or the WPML editor, you should get the same results both with a duplicated post or translating it independently. Hope it clarifies your questions, have a nice day.

October 30, 2018 at 5:11 pm #2862969

harrisD

Yes. Thank you

October 30, 2018 at 5:12 pm #2862993

harrisD

My issue is resolved now. Thank you!