Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Mateus Getulio 3 months ago.

Assigned support staff: Mateus Getulio.

Author Posts
June 28, 2022 at 1:04 pm #11559907

janS-38

I added a new language and the url hidden link, but when I put the url into the adress bar, it redirects to hidden link.

What to do about it?

June 29, 2022 at 12:50 pm #11567859

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thanks for your contact, and welcome to the WPML support forum!

Before entering the second language domain on the WPML -> Languages -> Language URL -> 'A different domain per language' section, you need to properly configure the DNS settings, in order to make all your domains (or sub-domains) point to your WPML-powered site. This is something that the company that sold you the domain should do for you. By chance, have they done it? Please let us know.

Moreover, make sure to fully read and follow our documentation related: https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/how-to-use-wpml-with-different-domains-per-language/

If the DNS settings are configured and the issue persists, we might be facing an interaction issue with a third-party functionality, in this case:

- Deactivate all the plugins that are not related to WPML
- Switch for a moment to a WordPress default theme like Twenty Twenty-one
- If the issue is gone, activate one by one to see with which one there is an interaction issue

Could you tell me the results of this investigation? Also, can you enable the debug mode? Please add the following code in your wp-config.php file:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
  
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
  
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
  
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Please check the following links to read more about debugging with WordPress.
- https://codex.wordpress.org/Debugging_in_WordPress
- https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging

After adding the code above, try to reproduce the issue again and check if you'll find a debug.log file inside the wp-content folder. If you locate it there, please send us the last lines here in the ticket.

Regards,
Mateus.