This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: We have some portfolio items that we want to present only in Polish lang, so we did not prepared translation in English. I've set option that if there is no translation, user should be redirected to the home page

But unfortunatelly user is redirected to the portfolio item with English link but with Polish content.

Solution: I just checked the settings of the site and this is the expected behavior. In case you just want to show the Portfolio in the language that has been translated then you need to need to go to WPML -> Opcje tłumaczenia -> Tłumaczenie typów wpisów -> Set portfolio to 'Przetłumaczalne - wyświetlaj tylko przetłumaczone elementy' -> Save the changes.

Relevant Documentation:

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 1 year, 4 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 24, 2018 at 6:51 am #2219856

andrzejK-9

Hello Guys,

We're translating our website from POLISH to ENGLISH and I've got some issues with portfolio.

We have some portfolio items that we want to present only in Polish lang, so we did not prepared translation in English.
I've set option that if there is no translation, user should be redirected to the home page: hidden link

But unfortunatelly user is redirected to the portfolio item with English link but with Polish content.
I tried to edit this item in English (hidden link) to see what will happen. But after clicking 'Edit Portfolio' I'm redirected to this ITEM IN POLISH (and it's even checked that there is no version in ENG: hidden link).

Link to a page where the issue can be seen:

hidden link
hidden link
hidden link

This unneceserry items are also visble at porfolio (and they shouldn't): hidden link

I also tried to choose Pomiń język (Dismiss language probably) at Setting of WPML but it did not help too.

Any idea what's wrong?

Regards,
Andrzej

May 24, 2018 at 8:37 pm #2225475

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 28, 2018 at 6:07 am #2236480

andrzejK-9

Hello,
I hope you received my answer :)?

May 28, 2018 at 4:31 pm #2240733

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I just checked the settings of the site and this is the expected behavior. In case you just want to show the Portfolio in the language that has been translated then you need to need to go to WPML -> Opcje tłumaczenia -> Tłumaczenie typów wpisów -> Set portfolio to 'Przetłumaczalne - wyświetlaj tylko przetłumaczone elementy' -> Save the changes.

Please let me know if you need further assistance.
Best regards,
Carlos

May 30, 2018 at 5:17 am #2248956

andrzejK-9

OK, I understand.
Thank you 🙂

May 30, 2018 at 3:34 pm #2252163

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos