This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.78 hours from now. Thank you for your understanding.

This topic contains 17 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 25, 2019 at 10:30 am

Pedro Henriques

Across several pages, links are being translated into wrong addresses.

Samples:

1. Bee2Citizen flip box at hidden link
- Original EN page: hidden link
- translated ES page: hidden link instead of hidden link
1. Bee2Waste flip box at hidden link
- Original EN page: hidden link
- Translated FR page: hidden link instead of hidden link
3. "Gestão de Resíduos Sólidos" at hidden link
- Original EN page:
- Translated PT page: hidden link instead of hidden link

How to fix it?

June 25, 2019 at 11:42 am
June 25, 2019 at 11:57 am #4084221

Pedro Henriques

I was chatting with Shekhar Bhandari and was it abruptly interrupted?!

How to generally fix? It's no solution to fix it by hand, it makes no sense then to have a automatic translated tool as WPML.

June 25, 2019 at 12:00 pm #4084345

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To exactly know the reason why the issue is happening, I would need to replicate your site on my localhost and perform further debugging, so could you please provide me a backup of your site so I can replicate your site on my localhost and perform further debugging.

To send a backup file you can use backups plugins, or use hosting services back up and send it using google drive, dropbox, etc to us. If you can, I request you to remove the uploads folder from the backup as it will be easy to download due to the size.

I have enabled the private reply so you can send those links in the private reply. If you use some backup plugins installed and you created the packages, you can just provide login details and mention us, we can download it from the site itself.
hidden link

Enabled the private reply for you.

Thanks

June 25, 2019 at 12:19 pm #4084421

Pedro Henriques

Shekhar,

Private reply isn't enable.

And should I translate those links? What should I view after clicking the pencil and what to to then? It seems that I always have the issue then because I've never saw a internal link field to translate and until recently they were being correctly translated. Can you show me a printscreen of what should I see and how to translate it?

Thanks

June 25, 2019 at 4:46 pm #4086265

Pedro Henriques

Internal links never showed up in translation screen and I think it's the way it is supposed to work.

If I change one the links with issues to external an external link, it then shows up in the translation screen, as it should.

If I switch back the internal link I would need, the outcome is the wrong translated link as WPML seems to be picking up a already wrongly translated link, which I don't know how it was created as I never translated internal links.

Now, how can I quickly fix it, as we have several internal links incorrectly translated (don't know how many...)?

For the migration, can't you use https://wordpress.org/plugins/bv-cloudways-automated-migration/ as we use with last WPML ticket?

Thanks

June 26, 2019 at 3:21 am
June 26, 2019 at 10:50 am #4091723

Pedro Henriques

Hello, Shekhar,

Migration is completed. It is password protected as I migrated it from a clone site. Please, use the credentials previously sent.

To fully understand this link translation process:

1. When I translate a page is it always created a domain with all strings, reason why we have several page-builder-shortcode-strings-00000?

2. Are these strings deleted when pages are deleted?

3. For the same link we have different translations in several domains (hidden link), with some of the translations with the issue in analysis. Is this because the same link was referenced in different pages?

Looking forward to your feedback.

Thanks

June 27, 2019 at 12:10 pm #4099951

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the migrations.

I performed the below steps and the results are as follows:
- Created a new page with the same link, the link is translated properly.
- Deleted the Portuguese translation and re-created it and the issue is not happening anymore.

Being so, I request you to follow any one of the above steps to fix the issue on your site and let me know if this helps.

I also consulted about this issue with our 2nd tier supporters and they mentioned it must be happening due to some old URL rule structures that were stored with the page and since it's not happening on the new page, the suggested to recreate the flip box.

Let me know if this helps.

Thanks

June 27, 2019 at 3:25 pm #4101285

Pedro Henriques

Hello, Shekhar

The issue is not only with the Flip Box element or Portuguese translation. And you suggestion, basically, is to recreate every single page with internal links (assuming it issue is only with internal links...) and translate it again into 3 languages??!! Where is the edge between your suggestion and creating a new site?! Or am I not interpreting your suggestion correctly?

Still, I would like you to answer the questions I place above.

And I'm not receiving notifications of your posts. Please, review it.

Looking forward to your feedback.

Thanks

June 28, 2019 at 3:42 am #4104267

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, I am talking about the internal links (Not just flip box), and I understand it's only needed to recreate for pages that have issues. I am sorry this is the only solution available now, as the issue is not easy to replicate on new pages and fresh installations I am still looking to find our ways to replicate on your site.

Further, I will pass your feedback to our 2nd tier support, but before that, could you please provide feedback on this?

#1
Can you recall if you have an old structure for posts (URL Structure, parents, child hierarchy) previously?

#2
Can you provide a few other pages links where the issue can be reproduced?

Look forward to your reply.

Thanks

July 1, 2019 at 9:53 am #4117543

Pedro Henriques

Hello,

Still not receiving the new post notification...

How do I delete "the Portuguese translation and re-created it and the issue is not happening anymore."? Is this an alternative of changing translations in String Translation (hidden link)?

#1: Yes, we have parent/child structure
#2: Original pages where all translations have similar issues identified:
hidden link
hidden link
hidden link
hidden link
hidden link
hidden link

Thanks

July 1, 2019 at 11:14 am #4118199

Pedro Henriques

Meanwhile I have correct the URL addresses from the String Manager interface (hidden link).

July 1, 2019 at 12:05 pm #4118573

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please follow the below steps to delete the translation:
- Backup your page translation somewhere
- Go to Dashboard->Pages and change the language from top bar to the selected language
- Delete the translation page
- Delete the page from trash too.
- Now go to the default page and add a translation.

Regarding the notification, could you please check if the settings are enabled as shown in the screenshot?

Look forward to your reply.

Thanks

July 1, 2019 at 3:26 pm #4120831

Pedro Henriques

Hello, Shekhar

The notifications were somehow disabled. Corrected.

The procedure you describe is going to delete the translation of all page, isn't it? I really wouldn't like to translate the pages again...

The changes I made in translation string module would be sufficient?

Thanks

The topic ‘[Closed] Links are being incorrectly translated’ is closed to new replies.