Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
Some links in the Elementor widget were not updating in the page translation and remained in the default language.

Solution:
We registered the Elementor widget for the Image Hover effect element using the WPML Compatibility Test Tools plugin. Here are the steps we followed:
1. We added the following custom XML configuration code to WPML -> Settings -> Custom XML Configuration:

<wpml-config>
  <elementor-widgets>
    <widget name="elementskit-image-hover-effect">
      <fields>
        <field editor_type="LINK">ekit_hover_image>url</field>
        <field>ekit_hover_image>id</field>
        <field>ekit_hover_image>size</field>
        <field>ekit_hover_image>alt</field>
        <field>ekit_hover_title</field>
        <field>ekit_hover_description</field>
        <field editor_type="LINK">ekit_hover_link>url</field>
        <field>ekit_image_button_text</field>
      </fields>
    </widget>
  </elementor-widgets>
</wpml-config>

2. We updated the Homepage in the primary language and then edited and completed the translation.

If this solution does not seem relevant to your issue, feel free to open a new support ticket by visiting the WPML support forum.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Osama Mersal 2 months, 2 weeks ago.

Assisted by: Osama Mersal.

Author Posts
November 22, 2023 at 8:19 pm #14902499

pierreM-27

Some links are not updating from page translation. They stay on default language as you can see on the attached,

The translation doesn't see them as a link or button.

Thanks

Pierre

WPML_Beton_urls_2.jpg
WPML_Beton_urls_1.jpg
November 23, 2023 at 5:06 pm #14910549

Subash Chandra Poudel

Hi Pierre,

Can you please try the following and see if it helps:

1. Edit the page with the issue in the primary language, make a small change to the page content or title, update it then try to edit the translation and complete it.

2. If it does not fix the issue, edit the translation again, and in the translation editor search for "http" or the URL of the button link from the top search box and see if you can then translate the link manually.

3. If it still does not work, can you please let me know more details on how exactly are those buttons and links built? Also if you could please share the page URL where I can see the issue it would help me further understand the issue.

Regards,
Subash

November 23, 2023 at 9:48 pm #14912257

pierreM-27

Hi,

Did all this. The website is about to be release in a week or two. It is not accessible from the front end. Only back end.

The plugin that causes the issue is ElementKits Pro on hover image widget. I know that WPML is fully compatible with this plugin.

It does not retain manuel editing from the language selection.

I can grant you access. Just let me know.

I cannot find anywere to edit the links.

Waiting for your respond.

Thanks

ElementKits_hover_links_2.jpg
ElementKits_hover_links.jpg
November 24, 2023 at 3:44 pm #14919109

Subash Chandra Poudel

Thank you for the updates. I would need to take a closer look at your site to troubleshoot the issue further. So would you please mind sharing temporary access (WP-Admin and FTP) to your site? Preferably to a test site where the problem has been replicated.

I have enabled a private reply for you to share the credentials securely, which means only you and I have access to it.

IMPORTANT: Please take a complete backup of the site first to avoid data loss.

Furthermore please let me know the pages/URLs where I can see the issue.

✙ I would additionally need your permission to make a copy of the site with plugins like Duplicator and deploy it on my local machine to test the issue further.

November 28, 2023 at 10:24 am #14937605

Subash Chandra Poudel

Thank you for the details.

The FTP details work fine but wp-admin credentials do not seem to work. I don't see any error only the screen as the attached image here. Can you please recheck the details then reshare the working details again?

I have enabled the private fields for you to share the details again securely.

Monosnap Se connecter ‹ Béton Pro-Vision — WordPre.png
November 28, 2023 at 2:57 pm #14941117

pierreM-27

Hi,
I have diactivated the reCAPTCHA from Itheme Security, you should be fine with same login credentials.

Sorry for that.

Thanks
Pierre

November 29, 2023 at 12:48 pm #14951045

Subash Chandra Poudel

Thank you for the details Pierre,

I registered the ELementor widget for the Image Hover affect element as explained in the next link:

https://wpml.org/documentation/related-projects/wpml-compatibility-test-tools-plugin/registering-custom-elementor-widgets-for-translation/

And came up with the following XML config code:

<wpml-config>
  <elementor-widgets>
    <widget name="elementskit-image-hover-effect">
      <fields>
        <field editor_type="LINK">ekit_hover_image>url</field>
        <field>ekit_hover_image>id</field>
        <field>ekit_hover_image>size</field>
        <field>ekit_hover_image>alt</field>
        <field>ekit_hover_title</field>
        <field>ekit_hover_description</field>
        <field editor_type="LINK">ekit_hover_link>url</field>
        <field>ekit_image_button_text</field>
      </fields>
    </widget>
  </elementor-widgets>
</wpml-config>

I placed the code at WPML -> Settings -> Custom XML Configuration and the issue seems to be resolved now after I updated the Homapage in the primary language then edited and completed the translation.

Can you please check and confirm?

November 29, 2023 at 2:55 pm #14952887
pierreM-27

Hi,

It works on the home page.

1- Howerver, I have added this widget to many pages:
hidden link
hidden link
hidden link
hidden link
hidden link
hidden link (2-witch top menu doesn't translate from french to english - Another issue to solve - See the attached also)

3-I have follow the link you provided, I cannot see the section page labeled WPML: ELementor Widget XML code. (as in the attached)

4-One last question, I do not use a child theme so after a update will I loose these changes??

Thanks
Pierre

New threads created by Subash Chandra Poudel and linked to this one are listed below:

https://wpml.org/forums/topic/split-language-switcher-not-translating/

Menu_Switcher_button_French.jpg
Menu_Switcher_button_English.jpg
WPML_Elementor_WIDGET_myscreen.jpg
WPML_Elementor_WIDGET.jpg
November 30, 2023 at 10:45 am #14961009

Subash Chandra Poudel

Hi Pierre,

1. For the new settings to take into action and the URLs to properly translate in the Widgets, please follow the following steps on the pages that are having this issue:

- Edit the page with the issue in the primary language, then update it will a small change in the title or content so as to trigger a translation update.
- Edit the translation and complete it.

2. Please note we try to handle only one issue per ticket, so I split the issue into a new ticket where we can handle the issue with the Language Switcher.

3. As explained in the document that I linked also linked next you need to Install the Multilingual Tools plugin to see the section. However, it should no longer be required as I already did the setup with the XML for you to support the Image Hover effect element

https://wpml.org/documentation/related-projects/wpml-compatibility-test-tools-plugin/registering-custom-elementor-widgets-for-translation/

4. The only change made was placing the XML code as explained in my previous reply linked next at wp-admin -> WPML -> Settings -> Custom XML Configuration. So updating the theme should not affect the issue.

https://wpml.org/forums/topic/links-are-not-updating-to-the-translate-language/#post-14951045

Regards,
Subash

December 6, 2023 at 9:01 pm #15012185

pierreM-27

Hi,

I really want to do it but I just can't find where to go on these pages:

hidden link
hidden link
hidden link
hidden link
hidden link
hidden link

I understand that I need to put the XML file in the page to make the links available but I don't see where?

Sorry, I don't get it. I don't have the same as your link in the attached.

Please provide, video, screenshot so I can do it.

Thanks

WPML_Elementor_WIDGET.jpg
December 7, 2023 at 7:58 am #15013687

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi Pierre,

Since Subash has a few days off, I will replace him here in the forum. I hope this is OK for you.

Please let me know which part of the mentioned pages are not translated.

I checked the pages, and the missing items on the English pages are the products. When checking the products in your dashboard, you don't have translated products yet.

Best regards,
Osama

December 7, 2023 at 4:56 pm #15019763

pierreM-27

Hi,

This section is translated in the homepage with help of your collegue. However, this section is on many pages and I'm not able to translate theme.

hidden link
hidden link
hidden link
hidden link
hidden link
hidden link

This XML has been done:
<wpml-config>
<elementor-widgets>
<widget name="elementskit-image-hover-effect">
<fields>
<field editor_type="LINK">ekit_hover_image>url</field>
<field>ekit_hover_image>id</field>
<field>ekit_hover_image>size</field>
<field>ekit_hover_image>alt</field>
<field>ekit_hover_title</field>
<field>ekit_hover_description</field>
<field editor_type="LINK">ekit_hover_link>url</field>
<field>ekit_image_button_text</field>
</fields>
</widget>
</elementor-widgets>
</wpml-config>

This doesn't help me to translate the pages mentionned before.
I just don't get it how it is done.

Thanks

WPML_Beton_Section not translate.jpg
December 7, 2023 at 8:16 pm #15020963

pierreM-27

Sorry, forgot to mention that only links URLs of the image hover are missing in the translation. Everything else is fine.

December 8, 2023 at 10:20 am #15024447

Osama Mersal
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for your update. Please check if the links work correctly.

Best regards,
Osama

2023-12-08_12-17-49.jpg
December 13, 2023 at 3:05 pm #15056483

pierreM-27

Fix the problem. Great support!

pierreM-27 confirmed that the issue was resolved on 2023-12-13 15:05:56.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.