This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 4 months ago.

Assigned support staff: Andreas W..

Author Posts
June 20, 2019 at 10:00 am #4058637

joakimJ-3

I'm trying to translate links, so they go to the right language. On some pages this has worked automatically, but on the start page the links on the swedish version still goes to the english pages.

I've tried to scan and adjust links, but it didn't help. What could be the problem?

This is the site:

hidden link

June 20, 2019 at 11:22 pm #4063563

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Is the homepage to 100% translated? Are you using one of the WPML Translation Editors?

In case the layout of the homepage is based on apage builder we can try to access the link URLs with a custom XML configuration.
https://wpml.org/documentation/support/language-configuration-files/

To help you faster, I've enabled a private message for submitting the debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Kind regards
Andreas

The topic ‘[Closed] Links don't appear in advanced translation editor’ is closed to new replies.