This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.20 hours from now. Thank you for your understanding.

This topic contains 7 replies, has 2 voices.

Last updated by jerremyW 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 9, 2018 at 8:20 pm #2801949

jerremyW

I am trying to: have button and icon links automatically being updated by WPML. I updated over 14000 strings, but it doesn't work.

Link to a page where the issue can be seen: hidden link At the bottom the country flags are redirecting still to the original language, while the text underneath is redirecting to the current (English) language.

I expected to see: URLs of buttons and icon links being automatically updated.

Instead, I got: the URLs redirecting to the original language. Duplicating the pages to update the URLs doesn't work.

I've followed the guide for custom XML and it's working for some elements, but especially images are not functioning (they remain their original URL). The same goes for icons. They still seem to be not recognized. I've used the XML code attached below.

<shortcode>
<tag>vc_figure</tag>
<attributes>
<attribute encoding="vc_link" type="link">href</attribute>
</attributes>
</shortcode>

and

<shortcode>
<tag encoding="base64">vc_icon_element-icon</tag>
</shortcode>

Any tips?

(see previous support ticket, which was still pending but automatically closed: https://wpml.org/forums/topic/links-from-buttons-and-logos-are-not-automatically-synced-with-language/)

October 10, 2018 at 3:24 pm #2804965

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Just a note that I tried using the credentials from the previous ticket and still, anything I click on other than the dashboard leads me to a 500 error. I need to be able to see the page so that I can take a look at the shortcode that is being used to create this content.

Also, please update to the latest version of WPML and addons. Let me know once the backend is ready for me to take another look. I have marked the next reply as private in case you need to update credentials.

October 11, 2018 at 1:42 pm #2808466

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for sending me access. I added the following to WPML -> Settings -> Custom XML Configuration:

<shortcode>
            <tag>vc_single_image</tag>
            <attributes>
                <attribute>link</attribute>
            </attributes>
        </shortcode>

Now, when I view the translation editor, I see the image URLs and it looks like the translations are correct. If you agree, you can mark them as complete and this should resolve the issue.

Please let me know if you need any further assistance and I will be happy to help.

October 12, 2018 at 5:06 pm #2812741

jerremyW

Thanks Lauren.

I'm trying to process the change, but I still don't seem to find the solution you attached for the images. When you look at this page: hidden link the images of the countries at the bottom are not recognized. I did update the page and published it again, but it didn't show any other result.

Could you tell me how to get the same result?

October 12, 2018 at 9:11 pm #2813082

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please open the translated page in the Translation Editor. Mark the URLs as "Translation is Complete". I have attached a screenshot of the fields I am referring to. Once they are marked as complete, do they direct correctly?

October 14, 2018 at 7:14 pm #2815796

jerremyW

Perfect, I've got the figures working. Now the only issue is that the following elements don't seem to work:
- vc_custom_heading doesn't seem to work anymore, could you briefly check it?
- the icons links never worked, which I identified as "vc_icon_element" and "vc_icon_element-link"
- the class "btn" doesn't work
Hope we can easily solve these and close the issue 🙂

<wpml-config>
    <custom-types>
        <custom-type translate="1">btn</custom-type>
    </custom-types>
    <shortcodes>
        <shortcode>
            <tag>vc_custom_heading</tag>
            <attributes>
                <attribute>text</attribute>
                <attribute>link</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>vc_single_image</tag>
            <attributes>
                <attribute>link</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>vc_single_image-wrapper</tag>
            <attributes>
                <attribute>link</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>vc_icon</tag>
            <attributes>
                <attribute>link</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>vc_icon_element</tag>
            <attributes>
                <attribute>link</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>btn</tag>
            <attributes>
                <attribute>text</attribute>
                <attribute>link</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>vc_btn</tag>
            <attributes>
                <attribute>text</attribute>
                <attribute>link</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>
October 15, 2018 at 1:30 pm #2817722

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

As the original issue is resolved may I kindly ask you please to open a new ticket for this question?
This will also help other users with similar problems find solutions when searching the forum as well as we avoid mixing lots of questions in one ticket.

Thank you for your understanding.

October 16, 2018 at 8:16 am #2820045

jerremyW

The issue with the figures is resolved! I'll open a new ticket for the other elements. Thanks.