This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Diego Pereira 1 year ago.

Assigned support staff: Diego Pereira.

Author Posts
October 1, 2018 at 1:50 pm

hannahb

I am trying to:
On the home page of the website, i have a product slider linking to dutch versions of the products.
Whenever i click a link, the following text is appended %2C and the link defaults back to . the UK translation.

Link to a page where the issue can be seen:
hidden link

I expected to see:
hidden link
for every link on the page - shoud end with /?lang=nl
Instead, I got:
hidden link
it adds %2c and the page diverts back to the UK Translation.,

October 3, 2018 at 5:54 pm #2785430

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @hannahb, welcome to the WPML support Forum!

Sorry for the delay. We are with a large volume of support requests at the moment. this is not usual in our forum.

Usually this type of issue is related to encoding. I have some questions:
- Does this problem occur only on the slide?
- Is this slide generated by the theme, by some plugin or created manually?

I also checked the settings of your server through debug log and saw that some items need attention:
Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 40mb only.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 3000. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

All the best,
Diego

October 5, 2018 at 2:54 pm #2791144

hannahb

Hi. In answer to your question, the slide is slick slider, it's not a plugin, its just purely hand coded into the theme. it does only seem to occur on the slide yes

October 5, 2018 at 7:00 pm #2791556

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

As this is hard-coded, it may be a compatibility issue. In this case, can we temporarily clone your website on our servers? This way I can take a look and run some tests without modifying the original website. If so, please install this plugin on your website: https://wordpress.org/plugins/bv-cloudways-automated-migration/

Please let me know if it's ok for you.

Kind regards,
Diego

October 8, 2018 at 11:05 am #2795721

hannahb

Yes of course - I have installed the plugin

October 8, 2018 at 8:46 pm #2797293

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thanks! I have duplicated the website. I will run some tests and send you a feedback soon.

Regards,
Diego

October 9, 2018 at 2:12 pm #2800375

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I noticed there is a issue related to ACF. The links are generated as a array, not a proper link, so it add some special characters on the link (see screenshot).

To fix this, go to Custom Fields and edit all "link" fields, setting them to "Link URL" instead of "Link Array".

After that, please try these steps to fix the links on the translation:
- Go to the edit screen of the page (default language)
- Change the language using the language switcher at the top admin bar
- If it displays a warning, click on "Edit Anyway"
- Edit the link fields (to point to the translated content) and save.

Please let me know if it worked for you.

Regards,
Diego

October 12, 2018 at 10:48 am #2811656

hannahb

The links were all pointing to translated content, but I've gone ahead and made the necessary steps you advised.
However, my issue is not resolved.
The first slide should go here (see image) - its actually taking you to /story/?lang=nl

October 15, 2018 at 12:15 pm #2817292

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I checked you website and some fields were still set as "array" (see screenshot).

I defined all fields as "Link URL" (both on original language and translation), then updated both pages (original and translations). Now it's working, you can check here: hidden link

If you need more help just let me know.

Kind regards,
Diego