This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Raja Mohammed 2 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 6, 2019 at 7:00 am

peterH-76

I am trying to:
Make the link to "imprint" and "data privacy" translated, too. The footer has to be defined in theme options (Laborator's "Kalium"-Theme) and it stays static exactly the text I entered in theme options, without options to (string-)translate it.

Link to a page where the issue can be seen:
any page. The "coming soon mode" will prevent access to the site, thus the phenomenon for all but admins.

I expected to see:
Options

Instead, I got: none

August 6, 2019 at 7:37 am
August 6, 2019 at 12:09 pm #4347119

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

It seems we have missed your chat. Could you please confirm whether you are able to add the theme options from the string translation admin screen?
https://wpml.org/documentation/getting-started-guide/string-translation/#admin_texts

I am unable to login to your site with the supplied details. I have enabled the private fields again please share the working login details. so that I can help you with the technical aspects

Kind regards
Raja

August 6, 2019 at 4:50 pm #4349649

peterH-76

Your admin should now work.
I found the "admin screen"-translation-feature, but could not locate any helpful feature within.

Sorry for the lack of orientation.

August 7, 2019 at 7:47 am #4352545

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I'm still unable to access the site, could you please provide new access, I have enabled private fields for you to securely share the details.

I will be able to help you once I have access to your site dashboard

August 7, 2019 at 8:47 am
August 7, 2019 at 5:12 pm #4357061

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I can see the strings are already registered in the WPML > String translation table under the admin_texts_theme_mods_kalium domain.

The footer text can be found under the name '[theme_mods_kalium]footer_text' Translate them and apply the changes as you do for string translation. Please refer to the screenshot if you need assistance.

I hope this helps you better

Kind regards
Raja

August 10, 2019 at 6:08 am #4374803

peterH-76

Wow, thank you. I am beginning to understand...
In string translation I find a whole number of texts that are assigned to be "english" but are, in fact, German. How do I generally reassign languages to strings?

August 13, 2019 at 9:01 am #4386303

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please follow the below stepst to change string language
1) Goto WPML > String translation Choose the string from the list
2) Click on Change language of selected strings button
3) Choose English from Change the language to: drop-down box
4) Save the changes and confirm String's Language is modified
5) Then you can translate the String to German

I hope this helps you better.

kind regards
Raja