This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
August 2, 2016 at 9:37 am #985882

Muriel

I am trying to: open product in English (.com website)

URL of (my) website where problem appears: hidden link

I expected to see: The single product to be shown like on the hidden link website (which is the same product).

Instead, I got: The homepage of hidden link is being opened instead.

Steps to duplicate the issue: Just try any product link in hidden link or a direct link: hidden link

Weird thing is... If I open the product in Dutch: hidden link and then use the language switcher to go to the English version, it works!

Already tried:

Please click on the WPML > Theme and plugins localization. Select the "Translate the theme and plugins using WPML's String Translation" option and click on the "Save" button.

Click on the Settings > Permalinks and click on the "Save changes" button. This will reset the permalinks.

This did not help.

August 2, 2016 at 9:40 am #985886

Muriel

An extra update:

When I am in a productcategory (does not matter which one) I can click the product to go to the single product.

August 2, 2016 at 10:09 am #986107

Muriel

Update nr 2:

It concerns only the products that have a price registered that do not work.

August 2, 2016 at 1:11 pm #986384

Thomas

Hello and thank you for contacting WPML support!

I see your server settings don't support WPML as needed.

### PHP version too low ###

Please increase PHP Version to 5.6.* and MySQL to 5.6.*

These values are also helpful:

.htaccess
php_value allow_url_fopen On

or

PHP.ini

allow_url_fopen = „On“

You may contact your hosting provider to make changes.

See more info about our minimum requirements here:

https://wpml.org/home/minimum-requirements/

After changes:

### Permalinks ###

Please re-save permalinks in WordPress -> Settings -> Permalinks

### WPML Cache ###

You may try to reset WPML Cache:

Please go to WPML > Troubleshooting > Support

1. Clear Cache in WPML
2. Clear Ghost entries

IMPORTANT: Please remember to backup your database first before you proceed! You can use a plugin for this if you like (search for WordPress backup plugins), also take a backup your project.

Please make sure you use latest versions of WPML plugins.

If still not working:

### Switch to minimal setup ###

1.) Deactivate all plugins
2.) Choose standard theme 2016
3.) Re-activate WPML plugins (latest version)
4.) See if problem persists

For further information or if you have any questions related to this ticket please do not hesitate to contact us.

August 2, 2016 at 5:10 pm #986919

Muriel

php_value allow_url_fopen On creates an 500 error.
The hosting provider does not want to upgrade their php-version anytime soon. 🙁

Clearing cache -> nothing.
Clear Ghost entries -> nothing

All plug-ins disabled except WPML and Woocommerce, with theme 2016 -> works
All plug-ins disabled except WPML and Woocommerce, with theme of client -> works

Enabled all plug-ins one by one.
Problem seems to lie with the redirection plug-in.

Will test this more tomorrow.

August 2, 2016 at 5:35 pm #986958

Muriel

Update:
The plug-in redirection was indeed the issue and has been removed completely.
Some items that have been translated do not appear translated anymore.

They are shown in the stringtranslation modeul as translated, but it does not show on the website. For instance the "from" price tag.

August 3, 2016 at 9:57 am #987777

Thomas

Great that you discovered the Problem.

Can you check following to translate with String Translation?

https://wpml.org/documentation/getting-started-guide/string-translation/

August 22, 2016 at 7:21 am #1013041

Muriel

I needed to delete the string and then re-add it. That worked.
issue is solved.