Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 32 replies, has 3 voices.

Last updated by Otto 1 year, 12 months ago.

Assigned support staff: Otto.

Author Posts
December 1, 2017 at 1:28 am #1446476

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Yaron,

Thanks.

I downloaded the theme, child theme, Redux Framework plugin, and listings pro plugin.

In a fresh install, as soon as I activate the theme (redux and listings-pro active) I get a fatal error. Just a fresh WP install, no WPML nor anything else.

Does the theme have a special install? Can you provide me with the original files? Am I missing something here?

Please apologize for all the back and forth, but I can't reproduce the issue to investigate further or escalate to our second tier support 🙁

Thanks for your cooperation.

Kind Regards,

Otto

December 2, 2017 at 7:06 am
December 3, 2017 at 1:16 pm #1447863

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Yaron,

Thanks a lot for all your patience and help.

Yes, this time I managed to reproduce the issue 🙂

And also found a workaround.

If you follow this workflow it works fine on my side:
Create a Listing with a gallery
Use the Duplicate option to translate it
Edit the translation (mark it to "Translate independently")

Following these steps, the images appear in both languages.

Alternatively, to fix the issue for a listing translated without the "duplicate" procedure, you can do the following.

Go to the front end to check the listing. Click on edit. You will see a warning that you should be using the editor instead of the regular edit page, ignore it.

Add the images to the listing and save.

I checked this workaround locally too and it worked.

Can you please check both on your side?

Let me know your results, please.

Kind Regards,

Otto

December 4, 2017 at 8:53 am #1448189

yaronK-3

Hi Otto,
I'm happy you managed to reproduce this issue on your end
i'm trying to follow you explanation, i'm OK until this step: Edit the translation (mark it to "Translate independently")
i don't see it, all i see is this : hidden link
this is a listing for Yom Tov Cafe.
can you pls explain where is the translate independently option?
thanks,
yaron

December 4, 2017 at 3:09 pm #1448727

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Yaron,

Unfortunately Otto is not available at the moment. I have read all your ticket and I can see that you have been working on it for several days and you are close for a solution. Could I kindly ask you to wait for Otto's return? He should be available shortly, otherwise, I'll take care of it. 🙂

In the meantime maybe the following screenshots will point you out how to:
1- Duplicate a post.
2. Mark it as independent by clicking on the "Edit independently" button.

Kind regards,
Andrés

December 6, 2017 at 12:50 pm #1450729

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Yaron,

Please apologize for the delay. I was on a sick leave.

Did Andrés's explanation help? I suggest trying that workflow on a new listing first. If it works, for old listings try this:
Go to the front end to check the listing. Click on edit. You will see a warning that you should be using the editor instead of the regular edit page, ignore it.
Add the images to the listing and save.

Let me know your results, please.

Kind Regards,

Otto

December 7, 2017 at 7:00 am #1451430

yaronK-3

hi Otto,
I hope you feel better.
i'm kind of lost here, do you mean that i edit the post via the customize option? cause i tried it and it didnt work, can you send me a screenshot of what you mean?
thanks,
Yaron

December 7, 2017 at 3:03 pm #1452007

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Yaron,

Please apologize I wasn't clear enough.

This is how I managed to translate, including the images a Listing from scratch:
hidden link

If I don't follow the duplication workflow, the images don't show in the translated listing. To fix this, this is how I proceeded:
hidden link

Let me know if it's clearer now and if it worked for you, please.

Kind Regards,

Otto

December 8, 2017 at 9:50 am #1452654

yaronK-3

Hi Otto,
forgive me for slow reply.
i'm just in the middle of migrating hidden link to a stronger server so i couldn't test your advised way of action.
i will do so as soon as my site is safely hosted in a new server.
one thing though... i noticed you have done your test on the default theme and not directly on my theme... i hope its the same because i have to say, some stuff works on the default theme without real gallery and didnt work on the actual site.
i will look into this as soon as i can and advise
thanks,
Yaron

December 8, 2017 at 1:23 pm #1452862

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Yaron,

Thanks for the update.

As mentioned, I have issues replicating your site locally, that's why I tried to reproduce the problem with just the theme.

I managed to do it and found a workaround that is working there, and I hope it works on your site too. It should, but maybe it doesn't. That at least will tell us that it is not a compatibility issue with the theme, but something on your site's configuration.

Let me know how your tests go and we will move forward from there.

Kind Regards,

Otto

December 8, 2017 at 3:07 pm #1452991

yaronK-3

thanks Otto,
in this case (when my site is fully migrated into the new server) there is no problem at all to work on my site directly.
i'll keep you updated after trying your suggestions
regards,
yaron

December 8, 2017 at 3:15 pm #1453000

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Great, thanks.

I will wait for your news then.

Kind Regards,

Otto

December 9, 2017 at 7:56 am #1453327

yaronK-3

Hi Otto,
I tried both methods you showed, listings called goodness (hidden link) and zappa (hidden link) and still no images in the gallery.
there were also something strange, i didn't have the gallery images ID's in the translation editor.
when i tried the second method of editing straight on the hebrew page (without the translation editor) it didn't work as well.
can you please try directly on my website? not on the site you created on your servers
i cant figure this out.. the images appear in the hebrew page but are not showing, only 1 image...
thanks
Yaron

December 11, 2017 at 11:29 am #1454070

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Yaron,

Thanks.

You mean here: hidden link, right? Is this a test site? Do you have a backup? Can I do some tests there too? Deactivate, reactivate themes and plugins, create new listings and images?

Sorry, for being too cautious, but better safe than sorry 🙂

Kind Regards,

Otto

December 11, 2017 at 12:14 pm #1454160

yaronK-3

hi Otto,
hidden link is my main site, however you can play with the gallery on any Hebrew listing, since i don't have anything to lose here, i did not translate most of the listing because of the gallery issue.
so if you want to play with the hebrew versions of the listing, go for it, it will not cause any damage.
regards,
yaron

The topic ‘[Closed] listing Gallery is not showing’ is closed to new replies.