Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 32 replies, has 3 voices.

Last updated by Otto 1 year, 11 months ago.

Assigned support staff: Otto.

Author Posts
December 11, 2017 at 1:28 pm #1454289

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Yaron,

Thanks.

I made it work here:
hidden link

What I've done:
1. I set gallery_image_ids Custom Field to "Don't translate"
2. I edited the images in the Hebrew gallery. I deleted the ones already selected and added new ones from the Media Library

As far as I can see it is working fine now.

Can you please try it? The step one is already done so you don't have to do anything.

You need to go to the front end and see a Hebrew listing. Click on the edit link from there to avoid the Translation Editor. Remove the old images and add them again.

For new listings, I think the "duplicate" workflow will do, so you won't have to do this every time you translate a Listing.

Let me know your results, please.

Kind Regards,

Otto

December 11, 2017 at 4:33 pm #1454594

yaronK-3

Hi Otto,
thanks for solving this issue.
i tried to follow your example, you can see my steps right here: ice_video_20171211-182039.webm , i made changes to the hebrew version of Yom tov cafe (hidden link ).
however, after deleting the images from the Hebrew version and tried to upload them again from gallery, it was not possible since i didnt have a search option (i just picked random images, and the good news is that they were uploaded lol), can you have a look? did you experience the same issue?
thanks.
Yaron

December 11, 2017 at 4:37 pm #1454602

yaronK-3

apologies, i attached the wrong file... here is the workflow link of my steps: hidden link
regards,
yaron

December 11, 2017 at 5:33 pm #1454674

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Yaron,

I am glad that we are moving forward 🙂

I created a fresh WordPress install with just the theme and I don't see a search box when adding images to Listings. Let me know if this is working for you. But, it looks like an issue of the theme to me.

If you follow this workflow for future translation, you won't face the issue:
Create a Listing with a gallery
Use the Duplicate option to translate it
Edit the translation (mark it to "Translate independently")

Just with the old ones, and there are not that much, right?

Is this a suitable workaround for you?

Kind Regards,

Otto

December 12, 2017 at 7:24 am #1455024

yaronK-3

Hi Otto,
i'm looking into the disappearance of the search option in the gallery, you are right its a theme issue, i recently uploaded some plugins, i believe some cause issue with the search bar of the gallery.
tell me please, if i will work on this work flow:
1. use the translation editor in order that the hebrew post will be associated with the EN one.
2. after finishing with the TE i will edit independently and remove image, and load new ones

i think it will work.
btw, about old listings... i don't have too much only about 900 listings to translate 🙂
regards,
Yaron

December 12, 2017 at 1:15 pm #1455558

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Yaron,

Yes, it should work.

But, even better: according to my results, you won't have to delete and re-upload the images.

When I translated a Listing using the duplicate option, images were copied correctly. So, just edit the Listing content using the TE should do.

But if it fails: yes, the steps you described should solve the issue.

Kind Regards,

Otto

The topic ‘[Closed] listing Gallery is not showing’ is closed to new replies.